Error ~ make sure Excel is installed

I am following the RPA Developer course. and I get an error in the excel section.
here are the details:
Message: Error opening workbook. Make sure Excel is installed. Exception Type: System.Exception RemoteException wrapping System.Exception: Error opening workbook. Make sure Excel is installed. ---> RemoteException wrapping System.InvalidCastException: Unable to cast COM object of type 'Microsoft.Office.Interop.Excel.ApplicationClass' to interface type 'Microsoft.Office.Interop.Excel._Application'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{000208D5-0000-0000-C000-000000000046}' failed due to the following error: Erreur lors du chargement de la bibliothèque/DLL du type. (Exception from HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY)). at System.StubHelpers.StubHelpers.GetCOMIPFromRCW(Object objSrc, IntPtr pCPCMD, IntPtr& ppTarget, Boolean& pfNeedsRelease) at Microsoft.Office.Interop.Excel.ApplicationClass.set_SheetsInNewWorkbook(Int32 RHS) at UiPath.Excel.WorkbookApplication.StartNewApplication() --- End of inner exception stack trace --- at UiPath.Excel.WorkbookApplication.StartNewApplication() at UiPath.Excel.WorkbookApplication.InitializeExcelApp() at UiPath.Excel.Activities.ExcelApplicationScope.<>c.<.ctor>b__44_0(WorkbookArguments args) at UiPath.Excel.Activities.ExcelApplicationScope.Execute(NativeActivityContext context) at System.Activities.NativeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

after checking the forum for a solution, I see that there are some users who solve it by deleting the Win32 entry in the register. but on my own, I couldn’t find it…
the error mentions the IID ‘{000208D5-0000-0000-C000-000000000046}’ but my register looks like:

Software specification:
Studio Pro 2020.10.0-beta.149 - 9/8/2020
Community License
EXE Installer
License Provider: Internal
Update Channel: Preview
Microsoft Windows 10 Enterprise 64-bit
.NET Framework Version 4.8

and “Microsoft 365 Apps for enterprise”


Hi did you manage to solve this issue? I encountered the exact same issue after working with UIPath for a couple of weeks, all set to WIN64, still not solved (even after running that experimental tool in UIpath studio (at home and tools).

unfortunately, NO. I was using office 365 and I didn’t figure out how to solve it.
in the end, I tried to install the old version (which is office 2016) and it works

Thanks for the reply, will try to not use any office application …


If you need to use .xlsx extension files only then you can use Workbook activites instead of using Excel application scope

This may avoid few excel application related problems, also these activities works even excel is not installed


Hope this helps you


still i am facing the same issue

Also facing the same issue

Facing same issue, did u find any solution?

Hi There,

Please use Excel Wrokbook activities, if excel is not installed, Excle work book activities doesnot require excel to be installed.


@suresh_chellappan Hey. I tried a lot of reinstalling and registry adaption - none of the approaches did lead to a working solutions. I then solved this issue because I found out that the Visio version was differing from the standard office version on my PC. This has lead to a problem in the library referencing - so deinstalling Visio (or upgrading to the similar version) has solved this.

Hi @BennyS , Could you please provide more info on the version of Visio and Office regarding your solution?
I have UiPath Version 2022.4.1 and MS Office 2013 (64 bit) MS Visual Studio 2010 Tools for Office runtime (64).

Have you already tried the common troubleshootings? Like office reinstall, registry edits etc?
For me, Visio has been the problem. I dont know if Visual Studio will be also a problem. But if you have the capabilities, maybe just try uninstalling visual studio since “theoretically” the versions differ from 2013 and 2010. I dont think that Visual Studio might be as a problem as Visio apparently is, but its worth testing at least.

I had Office 365 installed and Visio 2016, now I switched to full 365 and it works.

Lots of trial and error, In the end, resolved it by upgrading from MS office 2013 to 2016.

Thanks a lot for the quick replies.

1 Like

Thanks for the quick response. Actually, The development has already been done and we are facing this in production, so don’t have time to restructure the script.
Anyway found the solution by installing MS office 2016 ( previously it was 2013).