Remote desktop Closes off when I run the task from Orchestrator

orchestrator
citrix
rdp
p_qa

#1

Hello,
I am trying to run a task from Orchestrator, but that closes down my citrix desktop and throws an exception as below. When I run the task from the studio on my citrix desktop it works fine.

“Executor start process failed, reason System.Runtime.InteropServices.COMException (0x80071B9D): The target session is incompatible with the current session. (Exception from HRESULT: 0x80071B9D)\r\n at UiPath.UiSystemClass.OpenInteractiveWindowsSession(String bstrUser, String bstrPassword, UiOpenSessionFlags nFlags, String bstrApplication, String bstrAppArguments, Int32 nDelayMs, Int32 userToken, UiGenericOptions options)\r\n at UiPath.Core.Setup.OpenInteractiveWindowsSession(String username, String password, OpenSessionFlags flags, String application, String arguments, Int32 userToken, Int32 preferredWidth, Int32 preferredHeight, Int32 preferredDepth)\r\n at UiPath.Service.Impl.Executor.StartProcessInSession(Guid executorInstanceId, String username, String password, SettingsDictionary execSettings, IntPtr userToken)\r\n at UiPath.Service.Impl.Executor.<>c__DisplayClass15_1.<b__0>d.MoveNext()”
Start Time: 2018/03/15 17:30:39
End Time: 2018/03/15 17:30:39

Anyone knows what the problem is here. @badita @UiPathMaster @ClaytonM

Thank you


#2

Hi Sudhakar,

Did you change something in the UiPath.settings? Like width, height?


#3

I don’t think I did any changes in UiPath.settings. But I did in UIPath Robot Settings, added a robot. That is all.


#4

I don’t understand. The settings on the Robot machine?


#5

Connected to the robot created in the Orchestrator through UIPath.Robot settings in the system tray.


#6

That’s fine, so no other changes. Have you double checked the credentials when you provisioned the Robot in Orchestrator?


#7

Yes, I did. My domain name is dmzgz.local. But I read local to be excluded, so I am just giving dmzgz\user. So, I hope that is not a problem.


#8

No, I just want to make sure you have everything set up correctly.

I will add @qateam in the loop.


#9

Ovi,

          Any idea what the problem is?

Thanks


#10

We are still investigating and trying to reproduce. Can you please check if there are more details of this error in Event Viewer?


#11

That’s all I got.
let me tell you how I usually login to the remote desktop. I go to the gateway where I enter my username and password and then download .ica file which opens the remote desktop. Hope that helps in identifying the problem.

Thanks


#12

@shivnagsudhakar were you able to resolve this?

I am getting the same issue. When i run the job from orchestrator inside my aws instance, my remote desktop connection closes.


#13

Hi,

Setting logIntoConsole on the robot settings (you can do it under runtime tab in Orchestrator) enabled and false (by default it is disabled and false) should prevent this to occur.

Cheers


#14

So this is what happens.

When i select the process and run. my remote session to aws instance disconnects. Very strange.


#15

Changing the settings I mentioned on my previous post should be resolving the issue.
Could you give a try and let us know?

Actually, what version of the studio are you using. Thinking better about it your problem may be related recent windows update and the RDP lib used by UiPath.

A corrective was applied with the release under - something you might want to try you are using an older version.

Cheers


#16

Hello,
We are facing the same issue. tried all recommended steps, still no luck. any help is appreciated. thanks


#17

Proper logging off the remote desktop instead of just closing it off helped me resolve the problem.


#18

Thanks @shivnagsudhakar for the reply. I changed the LoginToConsole property to false in uipath.settings file and this resolved the issue for me.