REFramework xaml errors


#1

I’m trying to complete Academy 2 and assignment requires us to use REFramework however GetAppCredentials has xaml errors and can’t be executed (I’ve downloaded the one from GitHub).

Can someone assist?

Error is: Activity could not be loaded because of errors in the XAML. Using 2017.1 version.


#2

Hi Kemal,

Please make sure to have all the necessary packages installed. Maybe you need to install UiPath.Credentials.Activities package.


#3

That was it - thank you, you rock!!!


#4

Hey,

I was getting same error for GetAppCredentials.xaml at first,then i installed required packages, but now i am getting some another error for GetAppCredentials.xaml file only.

Attached SS of error.Please help with this issue ASAP.

Regards,
Shubham


#5

Please look into the list provided by Richard in this post:


#6

Hey @ovi,

Still I am not able to resolve this.
I installed v7 package, added some namespaces and checked for any other visible issues…but still nothing happening.

All other workflows are working properly but this GetAppCredentials.xaml from REFramework is having an issue.

Please Suggest.

Regards.


#7

Hi Shubham,

Check if there are any packages to be updated.
What Studio version do you have?


#8

Hi @ovi,

All packages are updated.
Version is 2017.16435 CE


#9

Hi. I am having the same issue running Studio 2018.1.2 Enterprise Edition on Win 10 Pro 64-bit. Without UiPath.Credentials.Activities the workflow loaded showed the credentials activities highlighted in red. On installing the latest UiPath.Credentials.Activities it simply failed on opening and I couldn’t access the workflow at all.
I uninstalled UiPath.Credentials.Activities to allow me to access the workflow, and then removed the problem activities, reinstalled UiPath.Credentials.Activities, and added the appropriate code elements, which then worked.
On comparison of the XAML file, the main difference appears to be 3 lines (92,96,102) where the credential activities occur. These all contain the code (xmlns:sads="http://schemas.microsoft.com/netfx/2010/xaml/activities/debugger") which when removed, the original GetAppCredentials.XAML works fine for me.
This same statement is also seen at the top of the code (line 6) and does not cause an error.

I know I have it working but I would like to know why it was a problem for me, am I missing something?