I created a bot for my team. I used StudioX. Bot is running fine in my VM but after publish and copy the project entire package from my hard drive zipped and email to my collague machine. Bot doest work correctly. Bot is able to click some targets but not all like it works on my machine.
I am not using orchestrator to add to certain machine. Locally just copy the whole pacakge zip it and send it.
Is their another work around.
Or is this known issue certain items dont work then you have to tweak it on their machine.



Can you please tell what kind of activities are not working

One issue can be if you are usinfg selectors as you cannot edit selectors in studiox they might be specific to your pages …so we need to re indicate them

Or better develop the object repository in studio where you have ability to edit selectors and choose reliable selectors and use them same across

Also if you are using any hardcoded paths then your username might be present in them and those folders might not be accessed as theya re not present on other systems



Usually when i log into my VM then i xan acces the page without credentials. If i use incognito mode then it prompts to log in.

Is there a sample you can share for edit selector and choose reliable selector.

Their is nothing hardcoded. Just using get text and click button.

I have group in other regions that i shared to and certain items are miss and it throws error.


Can you tell what errors its throwing

Generally when you get selectors you need to use ui explorer and make sure attributes containing numbers or so needs to ne removed…if you are using type into and all then even innertext is not preferred

Please check this


Error is basically unable to find the element. If i run in my machine it works fine.


Then you need to check the selectors only…please use ui explorer and indicate and check


Thanks will try that.

1 Like

Hello my collague still get element not found.
But in my machine i can access it normally.

If i take control and manually fix it then it works.

But then i have to do same on 20+ users.

Is this a known issue.

Bot can only run on 1 machine smoothly but not on other user machine.