Published robot path

Hey there.

I have the following situation: I have published a robot to oc which is supposed to, let’s say, get a xlsx file from the mail and move it to the desktop.
The issue is that when I go to the computer in which I run the robot, the file is not there, but the process seems to work fine.
I’m a little bit confused as I am not used to work much with oc.

So my question would be, where is the file being stored? The robot gets it and works with it, but it is not saved in the computer.



If the process worked on your machine, have you changed the path of the desktop to take into consideration the user path of the robot in your virtual machine? Ex: C:\Users\sebaaf96\Desktop ? Are you using a network path? If thats the case take into consideration that you should also use the full path ex \network\path\to\share\ and dont use the reference to the drive letter on your PC (assuming you have the network drive mapped)

I tried with the full path corresponding to that specific machine, like C:\Users\sebaaf96\Desktop.
However it also happens when I use relative paths inside the robot folder

When you run the process in your machine the file is moved to the desktop (or other folder) as you want it?
How are you saving the file? Are you sure the file is being created? Are you saving the attachment directly on the desktop or using a “move”/“copy” activity to move the file?

I’m using the ‘save attachment’ activity for mails.
The file is used, as the robot reads the info and completes the process.
Another thing that happens is that the robot should log some stuff in a txt file, but the file is never created in the machine., or at least in the path i want

I’m having the same issue. Though I am using the “Copy File” activity to duplicate a file. Were you able to resolve the issue?