Process finished due to no more transaction data Level 3 Client Security Hash

Hello,
i’m dealing with the Assignment1, Calculate Client Security Hash.
I’m struck with the error “Process finished due to no more transaction data” in the main flow, the level is the well known get transaction data. Process Transaction doesn’t receive any item. I tried many ways to solve it, but i can’t get out of it. As a last chance, i tried a personal arrangement, different from the “WIList” argument, but didnt’ work.
Could you please have a look at my main.xaml?
Thank you very much in advance.

Calculate_Client_SecurityHash_old.zip (554.8 KB)

1 Like

Hi Valman,

Please check the arguments first.
Regards
Archana

Hi @VALMAN

Have you tried resetting your data in the ACME system? try resetting them first and then running the application to see whether it gets any data?

Hello Lahiru, tried the reset this very moment. Didn’t work. The message is the same. I’m trying to verify arguments. I was hoping for a specific answer. Ty all.

Hi @VALMAN

I think I found the problem… Check the screenshot below

The out_ransactionitem argument is not assigned to anything in the place where you invoke this workflow…

and in the main workflow, I have few things that does not match to my above screenshot

The condition to move to Process from GetTransactionData is to check whether In_TransactionItem is not nothing and In_Transactionitem is of dataRow type. However, from the GetTransactionData.xaml, I don’t see any argument with the DataRow type that gets assigned to this variable. This is where the problem is… You will need to correct it to work properly…

2 Likes

Thank you Archana and Lahiru. I’ll do my best for correct it!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.