Problem with unattended robot and browser

When I run process from studio it works perfectly, but when I run process from orchestrator (unattended robot), browser open and web page loads inifinite. Than I connect to this machine via RDP, page immediately loaded and process continues successifully. What’s wrong with it?

14:43:40.4118 Trace {“message”:“Open Browser Executing”,“level”:“Trace”,“logType”:“Default”,“timeStamp”:“2019-11-05T14:43:40.4118234+03:00”,“fingerprint”:“82378f57-c005-42fe-b8ed-68a8c53efdcd”,“windowsIdentity”:“TEST-MACHINE\shady”,“machineName”:“TEST-MACHINE”,“processName”:“test”,“processVersion”:“1.0.16”,“jobId”:“fb8b3f98-c012-4d6b-8f2e-8d2a0a266ef2”,“robotName”:“test”,“machineId”:15747,“organizationUnitId”:45838,“fileName”:“Main”,“activityInfo”:{“Activity”:“UiPath.Core.Activities.OpenBrowser”,“DisplayName”:“Open Browser”,“State”:“Executing”,“Variables”:{“weight_raw”:“XX”,“weight”:“XX”,“tg_token”:"",“browser”:""},“Arguments”:{“ContinueOnError”:“False”,“Private”:“False”,“Url”:“”,“Hidden”:“False”,“CommunicationMethod”:“Native”,“BrowserType”:“Chrome”,“NewSession”:“True”}}}

welcome to uipath community
i didnt get this buddy
may i know the sequence of activities been used and the issue that you were facing

Cheers @shady2k

If process executes by orchestrator and there are no logged in user on Windows machine:

  1. Open browser UiPath.Core.Activities.OpenBrowser with specific URL
  2. Browser loading page infinitely
  3. Process throws error “Cannot find the UI element corresponding to this selector”, because page does not load

If I’m logged in via RDP when orchestrator execute this process, browser opens and page loading correctly.


Could you add some delay in TimeOut field of that activity and check once.

Delay does not help. After process started, I’m waiting for Open Browser Executing action in log. After that I wait until job failed. Than I connect via RDP I see browser with loading page and blank screen and page immedeately load and job finishing successfully.


Could you try with some other web application and check once. I want to see whether the issue with this web application or something else.

Different browser? IE?


I am not talking about browser. Please check with some other web application.

Ah, ok. Changed URL to another site, page still loading when I connect via RDP, but after that, loaded immediately.


It’s weird. Then try with some other browser once and see.

With IE page is loading, but it can’t find input field. Is it Chrome issue?


May be you Developed workflow based on Chrome browser and you need to change selectors based on IE browser then only it should work.

Yes seems like issue chrome browser. Have you installed chrome extension from Uipath studio or not ?

Ok, but I won’t use IE.

Yes, extension is installed.

1 Like

I have the same issue but with IE. When robot is in unattended mode the page is simply not loading the full content. When starting a session manually with RDP works perfectly fine. I have added plenty of delays, doesn’t help.

I am having a similar issue running unattended bots from on premise orchestrator with IE. I have delays in the workflow however I either get could not communicate with browser or if it does open browser with a very long delay, it cant find the element that should certainly be there.

Also when I RDP to the machine I see that the bot has opened multiple windows during the workflow. However when I run it using studio on the server there is no issue.

I have a similar issue with Chrome on 2 different bots, VMs,
Bot cannot find and communicate with Browser in unattended mode.

1 Like

Hi Team,

Is there any solution for the above problem of web page is not loading in unattended mode?.


I’m facing this issue too. Seems like it’s looking for a selector that isn’t present. oddly when I take a screenshot right before the activity, webpage is clearly visible but the UI element that works in attended is not visible in unattended job. However the suggested UI element from exception handling isn’t even available when I rdp in and try to debug in Studio…

Dear All

I also have this issue recently.
Uipath will have a hotfix ?
Or any best old version Chrome can try ?

Hi fellow UIPathers. I just wanted to pile on and say I have the same issue and have tried Chrome and Firefox which are my go to browsers. Has anyone tried Edge? I hope UIPath has a fix for this as it would be an issue if I always had to have a RDP session open on a laptop.