Problem with 'Type Into' Activity in Excel


#1

Hey guys, I’ve got a weird thing going on with the Type Into activity in Excel. I’m trying to process invoices into a big excel spreadsheet. There’s a list of debtors in the sheet, the robot should first write the name of the debtor on the invoice into the sheet. Then if it already exists, the robot can proceed to fill in the rest of the info. If it doesn’t exists, it should make a new debtor. When that’s done, it should again write the name of the debtor into the sheet to select it, but the weird thing is that the second time around it doesn’t type anything. All the other activities around it work fine (clicking the cell, etc), but no matter what I try, it won’t type. Have any of you seen this before? Or do you know what could be causing it?

The workflow, excel sheet and info I’m processing are attached below. The activities are in the ‘For Each Row’ sequence Thanks in advance!

Main.xaml (50.7 KB)
processed-invoices-17-05-2018.xlsx (10.7 KB)
boekhoud.zip (293.6 KB)


#2

Hi

Does write cell activity not work when you’re typing into the dropdown? Clicking individual cells in excel can be iffy.

Also, the second type into activity which you say is failing, the selector says name = A1… shouldn’t it be C2? I noticed in your first type into (which does work), there is no selector.

Good luck!


#3

I feel so silly, Write cell did the trick! :slight_smile: The only thing I’ve seen is that it then doesn’t check if the value is within the validated data, so there will be no error popping up if the debtor isn’t listed. However, we’ve just added it so I think we can safely assume that it’s listed.

Guess I was too fixed on re using the first part of the workflow. I still do think it’s weird though that it works the first time around, but not the second time.

The A1 was a test btw, to see if it would type into another cell. Accidentally left it in.

Thanks!


#4

Glad it’s working now :smile:

If you send the enter hotkey after the write cell does it still not check the validation?


#5

Nope, I tried to manipulate it with a false entry, but the enter key seems to hit on cell A1, even though C2 is in the selector. Afterwards it continues by filling in the info and hitting submit, without any errors. I also tried putting a click activity in between the write cell and enter hotkey, then you can see the cell being selected and the enter key being hit, but no error.


#6

I suppose you can’t confirm whether the validation works until the robot fails to add the debtor to the list though.

Hopefully it never fails anyway :stuck_out_tongue:


#7

True :slight_smile:

Ran into another weird problem now. When I execute the workflow while the Excel sheet is opened, it works totally fine. However, when I execute in when the sheet is closed it doesn’t validate the data. The sheet open (with the excel appliciation scope), it performs the first actions, but when pressing the enter button it pops back to the name that was in the C2 cell earlier, and doesn’t fire the error…

Do you know if there’s any difference in how Excel is opened when you do it by hand, of when it’s done with the Excel Application Scope?


#8

The only thing I can think of that might affect it is that excel application scope opens the files as read only by default.

For me, I would either as you say open it manually, or skip the data validation cell and check through the list of debtors directly to see if it exists.


#9

Thanks, but I found another way around it, by opening Explorer and double clicking the file from there, basically mimicking the way a human would open the file :slight_smile: