Issue with If, Type Into, Get Text, and Write Cell activities in Decisions demo video within Decisions, Iterations, and Scenarios in StudioX course

When I use the If, Type Into, Get Text, and Write Cell activities as I’m trying to replicate what’s being done in the Decisions demo video, I’m not able to choose cells from within the linked TransactionDocument spreadsheet (Transactions - May2022). I have the spreadsheet downloaded to the project folder and I have it open while I’m building the automation in StudioX.

If Activity

My If activity is nested within the Use Excel File activity and I’m able to link to the demo spreadsheet and rename it to TransactionDocument as indicated in the demo video. However, when I try to configure my If activity’s conditions, I cannot select the Indicate in Excel option and choose the proper cell E2. I get an error message that says “Excel is starting, please try again later.” I can only use the Custom Input to manually add the sheet and cell info.

Type Into Activity

I do not see a + sign in the Type This field that allows me to select a cell from the demo spreadsheet to input the Cash In, On Us Check, and Not On Us Check values into the 3 Type Into activities as demonstrated in the video. I can make the eye icon visible for that field and then manually type in the 3 distinct values from the demo spreadsheet.

Get Text Activity

In the Save To field for this activity, I can’t type a value into the field or select an option that links me to the demo spreadsheet. Basically I can’t fill in this field. If I open the Properties window for this activity, then I’m able to manually type in the sheet and cell number under Output–>Text.

Write Cell Activity

There’s no function within the activity that allows me to enter a message and select the cell to write to. It seems like I cannot fill in the What to Write and Where to Write fields. If I open the properties for this activity, I am able to manually fill Destination field using Custom Input and the Input field using Text.

Running the Automation

After building the automation in the way described above, I get an error message when I try to run it. It says:

We have detected multiple Excel processes running. It is recommended to have at most one Excel process running for the automation to work as expected.

Excel instance: 13976, file: Transactions - May2022.xlsx
Excel instance: 30116 not visible file:

Press Yes to force close them (Caution - This may result in data loss!). Press No to abort the execution. You can close the Excel instance manually and try again.

I do not have multiple Excel files open. I select Yes to run my automation. What I find is that there is now a second Sheet1 tab on my Transactions - May2022 spreadsheet with the transaction number on it. It’s not showing up on the original Sheet1 with all the other data.

What’s going on? My automation matches the solution provided for the demo but there’s some sort of error that doesn’t allow me to link to TransactionDocument spreadsheet as I’m building the automation to allow a quicker build - I have to manually input a lot of sheet and cell values and input values from the Properties window. And there is some sort of error that’s creating a ghost Excel spreadsheet during the running of my automation so that the transaction number is entered on another Sheet1 within the Transactions - May2022 spreadsheet.


Can you try changing the system activities package and the excel package and check if the issue persists…

You can go to manage packages and find these pckages


Thanks for the suggestion Anil. I think these issues are probably related to system packages, but it doesn’t make sense that more current packages would offer you less functionality.

I tried updating to the most recent packages for both categories and actually lost functionality! I lost quite a bit of functionality by updating to the most current SystemActivities package. I didn’t even have the Use Activity/Browser activity anymore. So I downgraded to a previous packages and at least got more activities back. I did upgrade my Excel Activities package and it addressed some of the issues, not all. After upgrading and downgrading a couple of times, I lost interest in trying to fix these problems as it’s no longer a good use of my time!

I think one of the biggest issues with these courses is that the demo videos are using different versions of the product and if there’s such a difference in functionality as we upgrade, it creates a lot of frustration for learners if we’re trying to follow along and replicate the activities.


In the very recent versions there has been major upgrades so the activities have changed and yes the courses are little outdated

For ease these have been upgraded…I have asked to change the the very recent versions in community because those would be preview versions which might have some issues…so it is ideal to use stable versions when you are starting…22.* are little more stable which you can try

Hope this helps


I was already using the stable packages when the issue happened. My Systems Activities was already the most current 22 package (22.10.5).

I’m now using the most current Excel Activities package (2.20.1). I tried setting the If Activity’s condition and it worked once in terms of linking to the TransactionDocument spreadsheet. The subsequent times I tried, I get the same error message as before. None of the other issues have been resolved. I do notice that if I have the Type Into Activity nested within the If Activity, there’s no way I can link to the TransactionDocument (no plus sign, just the eye icon). If the Type Into Activity is outside of the If Activity, then I see the plus sign in the Type This field that would allow me to link to the TransactionDocument spreadsheet but when I try to do that, I get the error message “Excel is starting, please try again later" even though my Excel spreadsheet is open. The same thing happens with the Get Text Activity.