Problem selecting button on webpage

Hi,

I am trying to automate clicking on a button. In the image it is the red button with ‘Zoek’ on it.image1.

The text cannot be selected but it has and ID hidden in lot’s of DIV’s a table and a form:

I cannot use hotkeys because it will not select this button. I have also tried an anchor without any succes, the latter might be due to my knowledge on how exactly to use it in this scenario. I have also tried webrecording. That worked a couple of times, but after that the element gets ‘lost’ again and cannot be validated.

I hope that anybody can shed a light on why I cannot click this button?

Dear @HansR83

Did you try with Attach Window as a container and placing click activity inside that?

hello @HansR83 have you tried the Click Text activity…?

The ‘window’ isn’t selectable when trying to use attach window. Only the actual browser seem to be in this case.

Try Anchor activity, to your left Find Image with higher accuracy in properties panel,

Other Alternatives: Click OCR Text, Click Activity only with co-ordinates.

Yes, I did. But the text itself isn’t even ‘selectable’.