Postman as External Application in Orchestrator On-Prem 21.10

Hi,

I have registered Postman as non confidential external application in Orchestrator On-Premise. After registration, I am unable to generate the OAuth 2.0 token. Provided all the details in Postman and once I clicked generate token, it takes me to On-Premise orchestrator to login but after login I am getting an error as “Cannot find the requested page” and it’s not getting re-directed back to Postman.

The same works with Cloud orchestrator without any problem and I can generate token. Normal authentication with On-prem also works fine and I can generate token if I give Tenant and credentials. Only problem is with OAuth2.0 token generation through Postman with On premise. Can someone help me?

1
2
3
4

@loginerror , @Cristian_Negulescu - Have you faced any issue like this with On-Prem? Can you please help me?

Hello,
I don’t see from your pictures what can be wrong.
You know I have this movie:

From my experience, you need to put again headers or links again in Postman and check for space or mistakes. If you are sure that you are right you can test also from power automate.
Did you put SSL OFF from the settings of PostMan?
Thanks,
Cristian

1 Like

Hi @Cristian_Negulescu - Yes I have followed your video and I can get the token with normal authentication method. SSL is disabled like you said and it works fine.

Only issue I am facing is with OAuth2.0 token generation with postman as external application in On-Prem. Not sure what am I missing since the same works with Cloud without any issues. Haven’t checked it with PowerAutomate, I will give it a try. Please let me know if you can check this in the meantime.

Enterprise Cloud is working properly:

Was able to resolve the issue. It was due to incorrect Auth & Token URL for On-Prem. There is an “_” (underscore) in cloud URL but not in On-Prem.

Cloud Auth ://https://cloud.uipath.com/identity_/connect/authorize
On-Prem Auth ://https://{OrchestratorURL}/identity/connect/authorize

Corrected the URL and it worked.!!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.