PostgreSQL with UiPath - How To


How can I connect UIPath to a Postgresql database?

Step by step guide


Please follow the steps below:-

  1. Install PostgreSQL driver (32-bit) from the following link Link. Navigate to the link and click on โ€œ PostgreSQL download site โ€ to open the download page. Then select the โ€œ MSI โ€ from the directories section and then select โ€œ โ€ or any respective 32-bit driver.

  1. Now, Create and configure the DNS using ODBC driver with PostgreSQL driver
  • In windows, search for โ€œ ODBC Data Sources (32-bit) โ€ and open it.
  • In the โ€œ User DSN โ€ tab click on the โ€œ Add New โ€ button.

  • Select โ€œ PostgreSQL Unicode โ€ and click on โ€œ Finish โ€.

  • A new Configuration window will appear. So you need to fill in the required details into it and then test if your connection is successful.

  • Once the connection is successful you can go ahead and use PostgreSQL with UiPath.

    1. Open UiPath Studio and drag a โ€œ Connect โ€ activity from Database Package.

  • Click on โ€œ Connection Wizard โ€ and select the โ€œ Microsoft ODBC Data Source โ€ and then click โ€œ OK โ€

  • In the โ€œ Data Source Specification โ€ select the โ€œ Use user or system data source name โ€ and from the drop-down select the recently created DSN source.
  • Enter the โ€œ User Name โ€, โ€œ Password โ€ and then test your connection.
  • Once the connection is successful you can go ahead and use the PostgreSQL Database with UiPath.

Hi @Prashant_08,
Here you can get the PostgreSql Connector.


1 Like

Thank you a lot ,I followed your steps and it worked very well ,your explanation is very clear

1 Like

Thanks a lot . It worked fine .

1 Like

I followed these steps i am able to connect to postgresql but i am not able to insert data with insert execute non query through is showing the error like this !error error|553x129

Works great without any further activities:
Test_Postgresql.xaml (5,1 KB)


Thanks a lot,it works

when i follow these steps, i got excpetion as below can any one help on this.

Thanks :slight_smile:

I hve installed but i am getting error. looks like this package is not supported in 2022.10 version.

any new releases?


Hi @venkat4u,

  1. Are you able to connect to Postgres normally without any drivers?
  2. If Yes, then do you give any certificate or use any other authentication approach?