Pick only executes on run, but not on debug

When I run my project, it executes the pick branch. When I try to debug through the project I’m getting held up because it just sits there, it does nothing, it doesn’t error out, it would just sit there all day if I let it…

I do have the System.Activities.Statements available under imports.
I created a test file with three pick branches, a delay and two element exists.
Nothing executes. It just kind of stops there, and does nothing.
When I run it, it works, and I set a log message to execute in each pick branch, so I know it’s working when I run it

I think I updated some packages to the latest versions and now I have an object repository, which is new… So maybe pick doesn’t work in the new version of whatever I updated… Should I downgrade some package or something to get this working? I just don’t know what this could be. Thanks for your help.

For me personally, i’ve always encountered weird issues using element exist in pick branches.
I tend to prefer find element for Pick activity. You can try and see if it works better.
The difference is that Find will throw exception if not found, whereas element exist just sits there if nothing is found after the timeout

In my real file, not the test file, it is using find element activity. That makes no difference. Same issue. And in the test file, it does work, but only when I run it. Same with my actual file that I’m working on. It’s gotta be some package I installed… I don’t know…

Can you share your project? Test or actual.

I tried your test case and it seems to be working when i run or debug.

Dependencies i used:
image

So I figured out what it is with my team lead. It’s one of the new features that were added. It’s a debug option “Execution Trail” When I turned that off it works. When I turn it back on it just gets stuck at the pick branch and does nothing, no error. So I suppose someone needs to fix that…

1 Like