Personal Macros suddenly got error and stops working

Hello Guys,

Previously, my macros from Personal.xlsb are working for months. Suddenly , all personal macros are stopped working and got the below error.

‘‘C:\Users\plasma\AppData\Roaming\Microsoft\Excel\XLSTART\PERSONAL.XLSB’!CopytoRaw_Productivity’. The macro may not be available in this workbook or all macros may be disabled."

I know how to call personal macro as I learned from below topic in forum.
Putted single quotes before C and ! in file path
https://forum.uipath.com/t/execute-macro-from-personal-macro-workbook/1855/14

I suspect that did UIPath Change this pattern?

It was working for 4 months, I didn’t update any robot, orchestra tor or activities package.

  • I can run these personal workbook marcos manually. So no macro error for sure.
  • Excel settings are all enable macros and added trusted locations ******
  • If I open the work book manually first, later run the processes, process can run that personal workbook marco, but if I use excel application scope and let robot open the excel and run personal macros , it cannot run.

Please help.

@Rohit can you help me bro since you are the originator for sharing how to call personal macros.

Hi @Alvin,
Have you tried to downgrade Excel Activity package? Please check it.

Hi @Pablito

Only One version in my Excel Activity, cannot select other version to downgrade.

image

Are you working on Enterprise or Community Edition?
Is your studio computer connected to internet?
Please check your Manage Packages settings:
image

image

hi @Pablito damn , bcoz of I shut down my orchestrator accidentally , thanks god if not all processes will be stopped .

I am on Enterprise Edition . will find out after my orche is up .

Hi @Pablito

I have tried

2.5.3
2.5.2
2.5.1
2.4.68

All not working by robot itself. Got same error .

But If I open the excel file manually first , then run excel application scope-> execute Macro then it can work.

Very weird behavior. Seems that it might be rather excel issue (update of excel?). Please try to contact with our Technical Support.

Thanks @Pablito if u have found out the reason please let me know.

I have tested in mutiple robots with simple flows (Just excel application scope -> run macro from personal.xlsb ) all got error .

FYI thanks