UiPath raise 'Cannot run the macro . The macro may not be available in this workbook...' error

I am running set of macros stored in a workbook file. In my laptop with Microsoft Office 365 Pro and Community studio, I get no errors. But the moment I start executing the same process for same excel file in the bot machine with Microsoft Office Standard 2016, it start raising below error.

System.Runtime.InteropServices.COMException (0x800A03EC): Cannot run the macro 'CopyData'. The macro may not be available in this workbook or all macros may be disabled.
   at UiPath.Excel.Activities.ExecuteMacro.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
   at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
   at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

I have added extra delay after excel scope activity, excel maximize as well, thinking this may be due to some loading issue, but still the same. What could be the reason for this? Some help is really appreciated as I have no clue what else can I do to fix this.

Problem is, it is not that all the macros are not visible. Because, I have this open workbook macro which is used to open anther excel. It has worked, but rest of the macros after that has failed.

Hey…! Are you using Invoke VBA or Execute Macro activity to run your Macro script?