Perform Right click

studio

#1

Hello, I started learning UI Path recently and following UIPath videos on their website. I would like to know how to perform right click as I can see only click and double click options. Need help in more videos would be really helpful.

Thanks !
Mahesh


#2

Hi,
You have option in click activity.
Please see Mouse Button property where you have an option to choose.

click


#3

Awesome, Thanks for quick reply.

Thank you so much !


#4

I want to execute one of the right click options of a document link in an email (Outlook Web Mail) to Save the document.

But I can’t record the sequence as a right button click is intercepted by the robot. If I record a sequence with a left click on the link then change the MouseButton click activity to BTN_RIGHT the robot still executes as though the left button was clicked. The right click pop up always disappears with the next button click (I can’t even capture the image!). So I don’t see how to record selection of the “Save link as…” pop-up option. Any ideas?

AJ


#5

you mean to say right click appears but unable to select the options (save link as )
on the menu ?
While recording hit F2 which give 3 seconds delay and meanwhile you can select that options (either by mouse click event or by sendhotkeys ex: Down ,enter )you would like to choose .

PS : beside right click and save as ,search is there any shortcut key for that same . Which makes your job easier via sendhotkey activity .


#6

During recording, when I right click on the link in the email, control returns back to the “Web Recording” menu, rather than displaying the pop-up menu.

image

I can go back to the Web page and right click on the link to open the pop-up menu. If I then click any option on the above menu, the pop-up menu disappears (it disappears on the next click no matter where the cursor is). This must be standard Microsoft Web Outlook behaviour - is there any way UiPath can inhibit that behaviour?

There is no shortcut key that saves the PDF referenced by the link.


#7

I need to use the popup menu to download the PDF because, although I am able to open the link to the PDF (by executing a “Click” activity), I can’t find a way of saving the PDF file displayed.

Ctrl-S will invoke the save to file dialogue but the “Hotkey” activity requires that an element be identified - but there aren’t any. The whole page is highlighted by the “Indicate element inside window” facility. Clicking on any part of the page throws an error:

image

The selector captured is: “webctrl tag=‘EMBED’ /”

Using IE is not an option.

Using “Indicate on screen” and F3 to “Select Region”, copies the selected area on the screen but when the activity runs (specifying CONTROL and S), the following error occurs:

Process AllStar Invoice has thrown an exception

Source: Attach Window ‘Httpswwwa Page’

Message: Cannot find the UI element corresponding to this selector:

Exception Type: SelectorNotFoundException

UiPath.Core.SelectorNotFoundException: Cannot find the UI element corresponding to this selector: —> System.Runtime.InteropServices.COMException: Cannot find the UI element corresponding to this selector:
at UiPath.UiNodeClass.FindFirst(UiFindScope scope, String nodeID)
at UiPath.Core.UiElement.FindFirst(FindScope scope, Selector selector)
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

I’ve tried “Set focus” and sending a RETURN (using “Hotkey”) before sending Ctrl-S, but both require an element so both fail for the same reason. Is there any way I can send a Ctrl-S to this page?

When you move the cursor to the top part of the page a sub-menu slides into view with a download button. But I can’t use that sliding menu as I get the “Flash and Silverlight” error (above) with the “Hover” activity or trying to use “Click”.

So I’ve reached an impasse (with another apparently simple requirement) … Is there another workaround I can try?


#8

Hello, why not using IExplorer ? too much of a trouble huh? …hey the ID seems to be random, perhaps that’s what is not letting you use the activity. try to use a wildcar and let us know.


#9

"IExplorer ? too much of a trouble huh?"
IE isn’t used.

"the ID seems to be random"
Apologies for leaving that “red herring” in place. The problem lies with just part of a workflow that, end to end, selects an email and then, somehow, saves it (either with the right click menu or by displaying it then trying to do a Ctrl-S) then selects groups of transactions from the downloaded invoice to put into different worksheets. So I’ve been testing mechanisms for just the save action, in isolation. Indeed you are correct to identify that a wildcard will be needed for the end-to-end workflow in order to work on the PDF link in all emails, which is different for every invoice number.

The problem with displaying the PDF (by clicking the link in the email) in order to execute a Ctrl-S seems to be that the invoice display page is not “in focus” when displayed by the robot. If the PDF invoice is displayed manually then Ctrl-S works correctly. If the robot is terminated after the page is displayed, manually issuing a Ctrl-S (or any other hot key) isn’t possible. You have to click on the page, anywhere, after which a Ctrl-S can be issued. I can’t find any way of delivering a click on the page (using the “Hotkey” activity), to set the focus or use the “Set focus” activity as both need to be associated with an element - and there are no elements identifiable on the page. Any ideas how I can set the focus to the page?


#10

Hello,

pardon me if I sound sarcastic… I meant, - because I know you tried, the use of iexplorer, because in my industry Ram consume is a challenge thats why I don´t use chrome, you know cost reduction,- getting back to the real deal, it will be much of a help if you share the xaml and I will be more than happy to help you with this automation.

if not possible, have you tried image automation as last resource?

regards.


#11

I’ve tried to find images and click on them, but focus will not transfer to the invoice display page. XAML attached for reference.

I would like to know why performing a right click from the Click activity on the invoice PDF link in the email executes exactly the same as a left click…

Process AllStar Invoice.xaml (45.3 KB)


#12

I’m looking into this I’ll reply as soon as possible. :slight_smile:


#13

Hi,

Did you ever get an answer on this one or found a root cause?
(cleaning up old bookmarks and this topic was on the list - I don’t know the answer either, but it is an interesting question)


#14

No, I never got to the bottom of this and actually abandoned the use case (even though it would have been particularly valuable) because I couldn’t find a workaround.

AJ


#15

Thanks for confirming.

@ovi - could you take a look? This doesn’t seem like it works as it should and is a potential QA issue.