Pasting a SAP table to Excel via clipboard fails

Hello, I’m automating a SAP data extraction process but when I do the
Get from clipboard → Generate DataTable sequence, the table gets pasted on a weird format
I’ll post the pictures to see if anyone has any suggestions

Aditionally manually it looks like this

And when the Robot does it looks like this

Hi @Daniel_Zarate,

Can you share the string form before converting datatable for combined incoming records?

Also for later you can change the cell ranges later.If you don’t want to deal with this, create a template and copy it every time you write.


Have you tried “Generate Data Table from Text”, you can format it with the wizard.

Generate Data Table From Text (

Hi @Daniel_Zarate ,
Let us know the configurations that you have provided for the Generate Datatable from Text Activity. Most probably it has something to do with the Column Separators, where you would need to Specify multiple (Two or more) spaces as the delimiter or Mark it as CSV format.

Also, we would need to look at Input String format for us to provide better suggestions.

Additionally, from SAP, there would be options to convert the table data into a CSV file or an Excel file. Do try to check if these options are available as well.

Hi @muhammedyuzuak here’s the extracted “paste” from the table

(had to sc because when pasted here it took it as a table directly)

How can I change the cell ranges or create the template? thank you for your response

I tried with CSV formating but there’s some data that has comma to separate pesos from cents and it messes up the formating
| i’ve just realized that it has this → | character embedded, will try making it a delimiter,
SAP isn’t letting me extract as CSV or EXCEL, tried that too

Thank you

Will try right now, if anything happens I’ll reply hopefully saying that it worked haha.

Thank you.