Passing variable into second workflow not working

Hello. In my app, I have an expression that passes the user’s email to Studio on runtime and stores it in an argument called UserEmail with direction input. It passes normally as I’ve checked with a message box the email is displayed. However, when I invoke a workflow from the main workflow, the second workflow returns a blank value even though the same argument name is included with direction Input. Why is it not carrying the variable to the second workflow?

can you send a print with the argument and the workflow?


The workflow is simple. As you can see, the first it prints normally, while the second time it doesn’t.

This is the argument in main workflow

This is the argument in second workflow

this first print came from your main? try use “in and out” in the second workflow

Same result. Believe me I tried them all. Setting to Out in first or second workflow results in a compilation error as well.

can you share your workflow with me?

I cannot unfortunately coz my project is a somehow confidential. But I just ran the same test on a new blank process with exactly everything the same and it worked. However, in my main project, the value is still showing blank don’t know why. I’m trying to figure out what might be the cause.

can you share only these twos xaml files?

you got two arguments in the same direction and maybe this is the cause of the problem, main to invoke we use “in” , invoke to main we use “out”, but if we got data that are in main and need to go to a invoke and manipulate this data inside the invoke to be and output in main we use “in and out”

alright sure one sec

yes I know all of what you’re saying is true. in my case, i want to pass it from the main workflow and only use it in the second workflow without getting it back. so its actually correct the way it should be: In and In in both workflows. the proof is that I also made a test earlier on a completely new blank process and it worked normally. But on my actual project, for some unknown reason, it’s not. I deleted the invoke activity then added it again to see if it might be a glitch, and even added two new workflows. Both resulted in an empty value. this is weird.

its hard help you without see the project, but if it is a glitch you need create other project

I will share with you one sec, I’m extracting the necessary files.

Check it out: (3.5 KB)

i found the problem, you need put the variable in the import arguments panel

They are both in the arguments panel :sweat_smile: :sweat_smile: :sweat_smile: :sweat_smile:

in this workflow that you send me, the variable arent in the imports panel

You can create them manually. Have you got into any solution? Did it work?

yes worked, when i put the variable in the invoke workflow imports panel

1 Like

Yes just tried it. Indeed it works. You did a great job! :smile:

1 Like