Package dependency error-System.IO not resolved

Hello Team,

I am trying to use activities “Path Exists and Move File” .
But the dependency package is shown not resolved System.IO

Tried “Repair Dependency”.But still not resolved

Please help here

It shows “System.IO”
4.3.0-Requested.Not resolved. Shows error(red)

@Teenu In the package manager upgrade this two packages Uipath.System.Activities and Uipath.UiAutomation.Activities

Yes, I have done these two

@Teenu Can you share screen shots of the error


It depends on some DLL’s in the windows.

Can you try getting all the files using Directory.Getfiles(Path) and assign to the variable of type array string. Then check if the file is there within that array.

Hey its resolved

1 Like

Sorry,its not resolved

I am unable to use MoveFile and Path Exists activities and it stops execution saying “uiautomation activities exception occured”

I am getting this error after the package starts to appear under dependencies which I may have added by mistake

If i remove this -it fails

Ok Hareesh, I will try

What am trying to do here is to move one file from one folder to another and I am using MoveFile activity

If I use this activity,then workflow breaks and it shows “UIPath automation activities exception occcured”

1 Like

@Teenu whats the studio version you are using

For that you don’t need to install System.UI right?

You can use that Move file activity directly? Any specific reason to install that? If no, then simply remove the dependency and try @Teenu

CE 2019.6.0

Yes,I dont need it. If I remove the dependency,the code breaks

Strange… Can you explain a bit please :slight_smile: … I just came to know that

Hey Hareesh,

Issue is resolved

I have selected “Simulate Click” for Type into activity which was breaking in CE.But works fine with EE Trial version. This was breaking the code. Thanks for the help and fast response

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.