Outlook get messages

Hello i am trying to read emails from a specific folder in my outlook with the get outlook mail messages function. The folder its called RPA and i have typed “RPA” to mailfolder
my email on account and made a output variable but still i am getting this error

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is: System.ArgumentException: The specified folder does not exist at UiPath.Mail.Activities.GetMailActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result) at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result) at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager).

I do have a folder in outlook thats called RPA so dont understand it.
THanks in advanced

@langsem Please follow below steps and see if that helps:
I suspect that the Outlook is opened with Higher privileges and Robot is triggered from Orchestrator with lower privileges because of which you are not able to identify the required folder in the mailbox. Can you check the outlook.exe file location and check the properties if you are trying to open it with Admin rights “Run program as Administrator” enabled. ?

  • Run gpedit.msc to open the Local Group Policy Editor. Expand Computer Configuration, Windows Settings, Security Settings, Local Policies, and Security Options.
  • Set “User Account Control: Allow UIAccess application to prompt for elevation without using the secure desktop”
    to Disabled

If that does not help then please check below 4 policy settings as well:

  • Set “User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode” to Elevate without prompting.
  • Set “User Account Control: Detect application installations and prompt for elevation” to Disabled.
  • Set “User Account Control: Run all administrators in Admin Approval Mode” to Disabled.
  • Set “User Account Control: Only elevate UIAccess applications that are installed in secure locations” to Disabled

Check if registry edits is required to include 32bit Outlook Interface.

Hi @langsem
mention in folder property as “Inbox\RPA”
and try buddy
Cheers

What do you mean by this ? Can you check the outlook.exe file location and check the properties if you are trying to open it with Admin rights “Run program as Administrator” enabled. ?

Run gpedit.msc to open the Local Group Policy Editor. Expand Computer Configuration, Windows Settings, Security Settings, Local Policies, and Security Options.
Set “User Account Control: Allow UIAccess application to prompt for elevation without using the secure desktop”
to Disabled

444

did this work buddy @langsem

afraid not

1 Like

if possible can i see the outlook mail property as a screenshot @langsem

remove the account property and keep it empty and
in mailfolder property mention as “Inbox\RPA”
uncheck the property onlyunreadmessages
if checked make sure you have some unread messages in your mail box
Cheers @langsem

None of the options worked :confused:

I made it worked :slight_smile: had to type inbox/e-postfolder/rpa

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.