Orchestrator Settings not loading and throws error “an error has occurred”

orchestrator
error

#1

Orchestrator Settings not loading and throws error “an error has occurred”


#2

Hello,

Can you provide some more information. Screenshots etc?


#3

Hi, when I click on settings I get an error saying “an error has occurred “ and keep loading. Nothing shows up.


#4

Hi,

Please check the event viewer on the Orchestrator server and provide us the error.
Also, what version of Orchestrator do you have?
Is Windows authentication enabled in web.config?

Thanks,
Andrei


#5

Hi, I am using 2018.3.3 version. On event viewer I don’t see any error related to UiPath.


#6

Not even quartz errors or something related to Windows authentication?


#7

Hi, I am not using windows authentication. I am trying to repair the installation - I will post if any issue comes. Thanks


#8

Hi, after reinstall also I am getting same error. I am unable to see any error in event viewer. We are not using windows authentication.


#9

It seems issue with getcalender function from main.js, but not sure what is wrong.


#10

I’m guessing that that’s what you see when looking in the developer tools console.
But the error is returned by the server so the reason why get calendar fails in js is actually on the server side.
Start by looking in developer tools -> Network tab and see the response code of the GET call that fails.
Logs might be necessary further since this should definitely be visible in EV if logging are correctly configured in web.config.
Please note that if you use multi node Orchestrator, the error can be visible in only one of the nodes EV

Thanks,
Andrei


#11

Please check this section in the web.config.


#12

Hi, I have checked the config and it’s showing same as you have mentioned for eventlog section, but it’s now showing any logs in evenviewer. I am using single node mode now to try this issue, also, I have reinstalled the orchestrator but still getting same issue. Sometimes website itself showing service is unavailable but loading after sometime.


#13

Please log a support issue for investigating.

Thanks,
Andrei


#14

Hi everyone.

I have gotten the same problem with Orchestrator version 2018.4.3

no error logs in event Viewer

Browser Console Error:
GET https://Host/odata/Settings/UiPath.Server.Configuration.OData.GetCalendar() 500
Error: main.js?v=2018.4.3.0:1

Have anyone found a solution?


#15

We have tried with new database and it worked. Try auto migration with new database.