Orchestrator on Azure installation problem


#1

Hi i am trying to install orchestrator on my azure cloud.

current status

I have 2 VM

my plan is to install orchestrator on VM1 and studio and SQL server on another VM2

while installing orchestrator i stopped at SSL certificate point where it is asking if i have a certificate or not ,my machine on Azure is connected to working group and not domain.

i am using windows server2012

i saw a point on orchestrator guide which said Uipath do not support installations in private Microsoft Azure instances.Make sure you have Web Deploy 3.5.

so i installed web deploy 3.5 also but no success.

Regards


#2

We have installed orchestrator on a cloud server and got it working. Not sure if it’s Microsoft Azure.
We used a self-signed Server certificate as mentioned in the orchestrator docs.
Have you resolved the issue by this time, since it has been 6 days that you posted it?


#3

hi @satishkumar yes we resolved the issue ,we also used self signed certificate.
thanx for the concern

Regards


#4

Fine then. Please go ahead and mark your reply as the solution.


#5

Hi guys @Samurai & @satishkumar ,

i see this items has been solved already 2 months ago, but i’m now facing more or less the same issue with the UIPath provided Azure Installation Script.

It says that it starts to deploy the data of the UIPathOrchestrator on the server, but in the end i don’t see a thing. Naturally in the end, it returns a “File unavailable” exception.

C:\users\jabberdoo\Desktop\UiPathOrchestrator\Publish-Orchestrator.ps1 : Exception calling “DownloadFile” with “2” argument(s): "The remote server returned an error: (550) File unavailable
(e.g., file not found, no access)."
At line:1 char:1

  • .\Publish-Orchestrator.ps1 `
  •   + CategoryInfo          : NotSpecified: (:) [Publish-Orchestrator.ps1], MethodInvocationException
      + FullyQualifiedErrorId : WebException,Publish-Orchestrator.ps1
    
    

You both completed the job, so can you give me some pointers where i need to look into to see where it could get blocked.

PS: I’m working with a Paas installation for the Orchestrator.


#6

Hi @KoenSL,

I’m facing the same issue. Is this resolved? Can you help me out with his?


#7

Hi sainatrheddy21,

it was a kind of firewall issue.
When i ran the installation from another VM (IaaS) in the same Azure resource group (without firewall) it worked fine.
Almost forgot to tell about the extra changes in “appsettings”.
I haven’t seen it mentioned in documentation, but as AcceptedRootUrls you need to add “http://localhost”.
(not sure if this was related to our specific installation)

regards