Orchestrator Manager - External Application Setup

I’m trying to up Orchestrator Manager OAuth Worfklow with on-prem 2021.10 Orchestrator. I keep getting unauthorized client response. Wondering if Redirect URL is set up incorrectly? What would be correct value for that in Orchestrator Manager, the URL of the VM where I am running Studio?


1 Like

Hey @jcarr79

Could you please show the snap of the configuration?


Do you mean in Orchestrator? If so, I currently have it set up like this with the VM name where I am running Orchestrator Manager as the Redirect URL.

Hi @jcarr79 ,

Orchestrator Manager is using “Client Credentials” to get the access token. So you will need to use Confidential Application with “Application Scope”. This will avoid the Redirect URL as well since its not mandatory for Application scope. Also you may need to select all scopes listed in the code while selecting in orchestrator and not just OR.Assets. Otherwise edit the code to have only OR.Assets in scope parameter. Orchestrator Manager is using all the scopes hard coded.

I could get the authentication successful with On-prem and Orchestrator manager. Let me know if it’s useful.


Auth is successful and gives me the Asset page.

1 Like

Thank you! Yes, it seems that the main issue was that I hadn’t granted the application access to all of the items Orchestrator Manager is looking for. I thought this would only matter when I tried to retrieve a certain type of item; glad it turned out to be this simple.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.