Orchestrator error: "Cannot connect to package feed, the URL may be invalid."

Hi!

I’m doing the Level 2 - Orchestrator 2018.1 Training and in practice 3 “Publishing your first process” I’m stuck in the “create new process” step. After clicking on “Add” on the processes page in the orchestrator (https://platform.uipath.com/processes) I get the following message “Cannot connect to package feed, the URL may be invalid.”
I’ve searched the forum and the internet and I can’t solve the problem, so I can’t continue with the training.
Does anyone have any idea on how to solve this issue?

Thanks in advance,
Jordi.
OrchestratorError

Hi @jordi.pique,
Kindly check the Orchestrator URL used while connecting the robo with orchestrator in robo tray.

For you the Url should be https://platform.uipath.com

Hope it helps

Regards,
Jyotsna

Hi, Jyotsna.

Thanks you for your quick answer.
Unfortunally it doesn’t work. I was using that URL as it is explained in the course materials (also in the field “Deployment URL” in the “Deployment” tab inside the “settings” options)
What it seems weird is that the status of the robot (locally) is “Connected, licensed” and in the Orchestrator the status is “Available”. Also the practice regarding the use of queues has worked perfectly, so the robot and the orchestrator somehow are “talking” correctly.
By the way, I see that I’m using version 2018.2.0 of the robot (instead of 2018.1.2 that is showed in you screen capture)

I am also facing this same error and I couldn’t find out the answer

I’m also facing the same error. Any suggestions ?

Weird part is, when i’m publishing the package from UIPath Studio, the publishing is successful. It is only at the Orchestrator that i face this error

EDIT:
Found the solution

If you are a Community Edition Orchestrator user, you also need to create your own feed in MyGet, and provide the URL feed and its API key in the Deployment tab, in the Settings tab.
If you use a private MyGet feed, please use the URL provided under Your pre-authenticated V2 URL (no basic authentication) . Please note that this is not a free service from MyGet.

ps: It took me two days of deep-diving into documents to get this info. Hit a like if this saved your time

4 Likes

Cheers a lot m8. I would not have solved this problem without your wisdom.

Good to know for people, you also need to change the settings based on the MyGet settings when pressing the publish package.

Specifically for me it meant:

  1. Create an MyGet account
  2. Create a feed in MyGet (I took a public one)
  3. Go to feed details in MyGet and make sure the Your NuGet V2 feed URL (Visual Studio 2012+) link gets pasted copy pasted into the deployment section of Orchestrator in the field Deployment Url*
  4. Go to feed details in MyGet and make sure the API key for consuming and pushing to this feed code gets pasted copy pasted into the deployment section of Orchestrator in the field API Key
  5. Go to UIPath and as part of the Design tab click publish (if you’ve opened a robot).
  6. Mark the “Custom” option.
  7. Go to feed details in MyGet and make sure the Push NuGet packages to link gets copy pasted into the custom url section of this screen in UIpath
  8. Go to feed details in MyGet and make sure the API key for consuming and pushing to this feed code gets copy pasted into the API key section of this screen in UIpath
  9. Press Publish
1 Like