Orchestrator (Error 404)

orchestrator

#1

I have finished installing Orchestrator using the Windows installer but when I access the Orchestrator website, I get this error page (attached). Any idea what’s going on here? I used the instructions here as reference: https://orchestrator.uipath.com/docs/the-windows-installer


#2

Tried instaling using scripts and it worked like a charm!!!


#3

Hello @argin.lerit !

Got the same issue, what did you mean by “installing using scripts” ? Is it by using command line parameters ? (https://orchestrator.uipath.com/v2018.2/docs/msi-command-line-parameters)

Thanks again.


#4

Additionnal infos : I can reach directly the error page https://Hostname/401.html (for example), but the link to the login page is not working (https://Hostname/Account/Login/)

In website source folder, I don’t have a “Account” folder. Is there something wrong with the deployment ?

Thanks again.


#5

Hello @Hyk! It’s this one: https://orchestrator.uipath.com/v2018.2/docs/installation-using-scripts

Hope this helps!


#6

Thanks for the links @argin.lerit !

I’ve tried using scripts but I still have the same issues :confused:

I don’t have problem creating database with a custom sql account, and the account used for application pool has full control of the physical folder of website.
And the installation succeeded with no errors.

If anyone can give me guidance/ideas, that would be much appreciated.

Thanks !


#7

What do you see when you navigate to https://hostname/Account/Login/?


#8

Hi folks!

What Orchestrator version are you trying to install?

When installing, did you use an old/existing database, or a new one? If there was an existing DB, you have to set this in web.config file: <add key="Database.EnableAutomaticMigrations" value="true" />.

Another thing, you are talking above about the installation using scripts. Since the 2018.2 release the script install is not supported anymore. Orchestrator will be installed using the .msi (Windows installer).

Thanks,
Viorela


#9

Hello @ovi

I’m trying to install v2018.1.
I just made another try :

  • uninstall Orchestrator
  • remove database
  • reinstall using .msi installer

Installation went OK but I still have the error mentionned in the first post when navigating to https://hostname/Account/Login/ :confused:
The database is up, accessible using the sql account used and is actually sysadmin.

Thank you for your help.


#10

Hi Argin,

Where can I download the installation scripts of Orchestrator 2017.1 ?

I tried to follow this guide but cannot find required scripts from its link https://orchestrator.uipath.com/v2017.1/docs/installation-using-scripts

Thanks,
Canh


#11

Hello Canh,

@ovi mentioned above that this is no longer a valid method of installation.


#12

I would like to install Orchestrator version is 2017.1 (not 2018.2) with the script method. Is this feasible now?

Thanks for your help!
Canh


#13

Hi @Hyk,

Have you solved the problem? I have the same problem after install Orchestrator v2017.1 using the Windows installer. Could you please share with me your solution?

Appreciate,
Canh


#14

Hello @dqcanh

I wish I had a real solution.

I tried on another server, and it’s working correctly.
It’s probably due to privileges/rights given to the user that performs the installation (or another user ?) but I have no clue and can’t find any differences.

Contrary to the rights for the DB user, there are no indications in documentation related to the rights needed for the windows part user :frowning:


#15

@Hyk,

Thanks for your response. I used local Administrator for all the installation. Did you ?

I’m now trying to figure out if I missed any prerequisites or configuration. Especially for things related to the IIS application pool “UiPathOrchestrator2017.1”, Orchestrator and it’s website. Do you have any tips for this?

Thanks,
Canh


#16

Hi @Hyk,

Just want to make sure if you followed exactly step by step in the installation guide below? Or Did you add some custom steps / settings for Orchestrator installation to make it worked?

Prerequistes: https://orchestrator.uipath.com/v2017.1/docs/prerequisites-for-installation
The Windows Installer: https://orchestrator.uipath.com/v2017.1/docs/the-windows-installer

Thanks a lot for your time,
Canh


#17

Hello

I’m sharing answer found with the help of UiPath Support :

  • in IIS console, go to Orchestrator website, feature "Authorization Rules ", try leaving only the rule:
    “Allow - All users”

I had the rule “Deny - Anonymous” that was inherited and caused the error. It was deleted and it’s now working well.

Hope that helps