Orchestrator Credential not working for SAP Password

orchestrator

#1

I just created an asset as a credential type which includes the user name and a password. Of course I cannot see the password that I’ve entered. For sake of this issue, let’s say the password is 1234pass

When running the automation, I used the Get Credential activity to pull these values from the Assets. The variable I assigned for the password was set as a secure string. This all makes sense.

The user name is typed into the field correctly. In the password field, though, instead of the password I stored in the orchestrator, 1234pass, what is typed into the SAP password field is actually the type - “System.Security.SecureType”.
I could see it was typing too many characters in the password field so to try and see what it was doing, I added a message box to see what it was entering.

If I use a non secure asset of text type it works fine but it is not secure.

Has anyone seen this and can help us?

Thanks!
Mare


#2

Hi Mare,

Which activity are you using? ‘Type Into’ or Type Into Secure Text’?

image

Have you tried the latter?


#3

Thank you Andrew! Good to see you! Yes that worked!!
I wish this had been clearer in the documentation! :slight_smile:


#4

It’s great to hear from you, the last name threw me!


#5

Thanks for mentioning Type Into Secure Text because that worked awesome!