Orchestrator "could not find Main.xaml"

orchestrator

#1

Hi,

I’ve tried to publish & run a simple “Hello World” project into our on premise instance of Orchestrator, and that works fine.

However… when I then published my real project (which works fine locally) into Orchestrator and tried to run it… it immediately faulted and presented me with error:

Info : “Execution error : System.Exception: Could not find file ‘C:\ProgramData\UiPath\Projects\My_Real_Project.1.0.6401.31709\lib\net45\Main.xaml’.”

At first I figured I was seeing this because I had renamed Main.xaml to something else after having watched the UIPath training videos… but I changed the name back to Main.xaml to see if that would fix it… but I still see the same error.

Not sure where to go with this?


Unable to run process from UiPath robot tray
#2

Oh I figured it out. I forgot to “Use” the latest version I uploaded on the “Processes” page.

Are we not able to rename Main.xaml though? I was pretty sure that the UIPath YouTube videos showed it being renamed. I’ll have to double check.


#3

Hi,

in the projects root folder there’s a file called project.json. If you open that in a text editor you will see a line such as:
“main”: “Main.xaml”

There you can change what workflow the robot interprets as the Main/Starting point. Useful as well if you want to test just specific parts of your process.

BR,
Topi