Orchestrator API - You are not authenticated

Hi, I am following the instructions at https://postman.uipath.rocks/ using Postman app to send and receive HTTP messages from Orchestrator

Currently at the section 2. Releases - Get by name

It seems pretty straightforward:

  • For Headers, I specified the Tenant Name from Orchestrator API Access and Folder ID from the Orchestrator URL
  • For Params, I entered the name of the process as ProcessKey

I have checked these and tried entering in variations but I am still encountering error

"error": {
    "code": 0,
    "message": "You are not authenticated!",
    "details": "You should be authenticated (sign in) in order to perform this operation.",
    "validationErrors": null

I also attempted to authenticate using section 1a. Authenticate (Cloud), I am able to use the API to receive a successful authentication response. However when I run 2. Releases - get by name again I am still encountering this same error.

Any help on how to access this API?

1 Like

I have exactly the same problem. Help!

Somebody already fixed this problem?

I am getting the same issue, intermittently. I am using the API through python and it is bringing back the bearer token fine. But when I either go to add a queue item or get a transaction item data it says “you are not authenticated”. However, when I then go onto the machine and log into the cloud platform https://cloud.uipath.com/ then try it again it works.

Did you check the permissions of the user you are using for your http request? Maybe try giving him a role with all permissions. If that works reduce them.

otherwise i’m remembering a weird behaviour when performing http orchestrator requests with the activity in studio. got the same problem there and the issue were the roles of the robot itself.

I have the same problem. I’m desesparate.

Maybe theses pictures of my orchestrator users will give you some insights @schwarzp ?

Can you allocate your User the Robot role too and check the requests again?

I tried to add the Robot role to my users. It didn’t change anything.
I will do some reasearch on this:

It came to me that maybe this happening also because of my workplace’s proxy connection…

Hi @VPetrini,

i just found an old mail where UiPath Support helped me with the Orchestrator Http Request activity. Maybe there is something new for you:

Issue Description : Trying to start a job via the orchestrator API using " Orchestrator HTTP Request " activity.

Actions performed :-

  1. We had a look into the issue and could see that even after giving the JSON Payload in the correct format we were still getting an error.
  2. The error was “You are not authorized”.
  3. This error comes when we do not have enough permissions to execute the API.
  4. We checked the user’s role and could see that it had an Administrator Role already defined.
  5. But to use the " Orchestrator HTTP Request " activity the user needs to have Robot roles assigned and with respective permission concerning the API.
  6. We assigned Robot Role and gave the required permission which was Create, View on Jobs, Process, and Packages.
  7. After making the above changes the issue was resolved. We were successfully able to make an API call using Orchestrator HTTP Request activity.
  8. It was working fine from Postman and Swagger as were authenticating their first and then starting the Job. Whereas in Orchestrator HTTP Request activity there is no need to authenticate.

Resolution :

  • Assigning Robot Role and giving the required permission which were Create, View on Jobs, Process and Packages resolved the issue.

Maybe you can check my attached code example too. That is one of our custom libraries to start a new job on orchestrator via api, because the http orchestrator request was not working for us.

I think you have to install the UiPath.Web activities package before using my code.

StartJob.xaml (23.7 KB)

Ok this one is the good one :') ← pain

My first mistake was to not download the UiPath postman package and set the request myself

When you do download the package, you apparently don’t have to take care of the token like they said:

What about Authentication and Token Refreshing??
Don’t sweat it. This collection uses those environment variables to take care of it all automatically in the background. Just press send and your calls will go through without a problem :wink:

The package create automatically a variable with the token as value:

But make sure that the Body tab is set to “row” and “Json” and… that it contains the actual body

Source :

Make sure that you set all your variables correctly:


If you make all the request yourself, without downloading the package:

-Do what I do previously about variables and the Body tab
-The Authentification request doesn’t need any type of token in the Authorization tab

-All the other requests need to have the token type set to Bearer Token and the Token area is set with the token generated previously without quotes""

Now I can finally use Postman and the API :stuck_out_tongue:


Add the authorization code in header with bearer keyword.And it should work.Authentication here means authorized (kind of)

Hi forum,
I am also facing the same error. I have all permissions, I have used bearer keyword, also folder id and client name in header section. Still I get the message as “You are not authenticated” what can be the reason?
Thanks in advance

Hi forum,
I was also facing the same issue for long so what I did was
This the link which you get on orchestrator → UiPath

so what I did was, I replaced the link in the docs->
https://cloud.uipath.com/odata/Releases?$filter=Name eq ‘all_activities_DocEnv’
UiPath eq ‘all_activities_DocEnv’
And now it works fine.
Let me know if it works for you


i solved this issues with the specific roles and also giving web access to the bot user in Orchestrator (on prem).

also giving web access to the bot user in [Orchestrator] (on prem).

…user should not be deactivated as well (on prem).

Thx :slight_smile: solved my not authorized error.

I’m kinda confused why It dosn’t work with the header tho.