Open folder works for some paths and not others


#1

Hi all,

I’m running into a problem in which UiPath’s Open Applications activity accepts some folder path arguments and not others. For example, using the two strings below (testPath1 and testPath2), UiPath will correctly open the testPath1 folder while failing to correctly open the testPath2 folder (it opens to the default My Documents folder instead)
testPath1: “C:\Users\dzhou\Documents\XX\Return Print Files”
testPath2: “C:\Users\dzhou\Documents\XX\XYZ\Test Print Files\Test 2\Factory Shoppes, Test”

Since both variables are under 80 characters and there’s no other difference, I’m not sure why this would be the case.

image

Has anyone experienced this and were you able to figure out a workaround?

Thanks!


#2

Hi @dzhou
I understand that your “WorkingDirectory” field is empty, and the folder path is stored in “Arguments”. Have you tried to go to the selector and untick the title part, so it is omitted? It worked for me in similar circumstances, as advised by @selrac in Open folder.
omit


#3

Hi @PAD! Thanks for the reply.

Here is what my selector looks like. I was thinking that might be the case as well, so I had removed the title and even the CabinetWClass.

Update: I tried a few different folder paths and it looks like the character length is causing it… Has anyone else experienced this? I’m just surprised by the character limit if this is the case.


#4

Have you tried to play with the index part instead? Like wildcard it, or omit it?


#5

Hi @dzhou

It is not the length, but the comma in the filename. For some reason it is breaking the path.

Try this, it worked for me with a test path:
testPath2: “C:\Users\dzhou\Documents\XX\XYZ\Test Print Files\Test 2\Factory Shoppes"", Test”
(adding two quotations before the comma "")


#6

@loginerror

This worked like a charm. Thanks for your help!


#7