Open Browser Error 2019.10.0 Beta484

Goodmorning everyone,

I’ve got a serious problem. I’ve created a big robot that did work perfectly. But suddenly the version of UiPath went from 2019.9.2 to 2019.10.0 beta484 version. The open browser activity doesn’t work anymore. Ill post a screenshot bellow.
The error message says: “Open Browser: Cannot communicate with the browser, please check the UiPath extension.”

BrowserError

Do you guys have any solutions? I would like to know if it is possible to go back to the older version.
The robot runs on a RDP server.

Thank you in advance

Greetings,
Tim

Hi @Timaahb,
which browser are you working with?
Make sure the browser extension is configured

Hi Sourav,

Thank you for quick reply!
The extension is installed correctly.
Chrome gives the popup message: UiPath Extension Crashed.
Everything is configured correctly. I have worked with the extension multiple times.

Minor update,

My co-worker found an sort of workaround. IF there’s already a chrome browser open. The “Open Browser” activity works. If there’s is none. It chrashes.

This is not the intention, I assume.

Greetings

1 Like

Another update. Switched to the stable version. 2019.10.0 Also doenst work.
It works on 2019.2 but UiPath auto updates when i open the file.

Thank you advance

Hey @Timaahb

As a work around, can you try Start process activity to start/ open the browser. Then you can use attach browser to continue the work from there…

Give it a try and see whether it works out for you

1 Like

Hi @Timaahb,

Can you help us investigate by sending a crash dump of the process ChromeNativeMessaging.exe if that is what is crashing? There is a short guide for collecting it here https://www.uipath.com/kb-articles/how-to-collect-crash-dumps

Thank you,
Dan

@Dan_Munteanu You make me feel like a complete noob. I cannot find the dmp files on the RDP server… They are not located in the %TEMP% folder. Or I’ve looked the wrong way. Any suggestions?

@Lahiru.Fernando Also a crash. Thanks for the idea though!

Really? That’s weird… at which point did it crash?

Same as before. It just opens the browser. Uipath chrome extension crashes and the chrome browser is not usable.

@Timaahb Absolutely no my intention ofcourse. Let’s gather some more information about the system.
Windows Version
Chrome Version
UiAutomation activities package version
If you open the browser manually, is the ChromeNativeMessaging.exe running in task manager?

Try once by installing old versions of chrome and then extension.

@Dan_Munteanu

Chrome Version: Version 78.0.3904.87 (Official Build) (64-bit)
Windows version: Microsoft WIndows 10 Home (10.0.14393 Build 14393)
UiAutomation Activity package: v19.7.0 (i did update it to the newest version but no improvement)

Chrome Native Messaging Host 32bit is running when i start manually

i can try. But it’s still weird that it works on every device. We all have the same version of chrome installed. It only doesnt work on the RDP server.

Then it will be issue with that RDP server.

That’s the weird part. It did work before. Until the auto update to version 10.0. So i guess there’s a small bug in the new update.

oh ok… tag once this issue with login error and all and if it is working with old version then use old version or any stable version.

hi,
I’ve got the same problem. I tried using chrome and firefox and they both crash when using “open browser” on the RDP server.
anyone found a solution?