OCR Screen Scraper Wizard gone; CV Get Text doesn't work

Hello everyone,

I have a workflow where I’m trying to extract data from standard German IDs:

Sequence2.xaml (100.4 KB)
Pictures: 1,2

Somehow, UiPath keeps throwing weird errors my way. Everything worked well earlier, now I changed laptops and it can’t find the same parts of the pictures - CV Get Text just misses out the last name as well as the place of birth (potato quality because I took the picture on my phone while holding down the mousecursor to show it):

So I tried redoing the whole desktop-recorder-shindig, but suddenly I don’t get the results window anymore - this here:

And the OCR results thus come up empty.

I also tried copy-pasting the whole thing into a new sequence where the screen scraper wizard works again, but it just won’t paste.

So, what the heck? Does anyone know what to do here?

Thank you all so much in advance,


I have used CV Get text and was successfully able to get last name and Place of birth from the attached image.

Refer the below workflow

get recent file.xaml (45.9 KB)

So how are you indication on screen.

To try it out, in the CV.getText, click indicate and do a box selection in the wizard, instead of clicking a word. After that you will need to pick an anchor for it. At runtime, it will scrape the whole area of the selection. Very similar to scrape-relative

Hey there,

Thanks for your reply. Drawing the box around and using an anchor is exactly what I did for both:

However, when I put in a message box to show me the variable “DateOfBirth”, it comes up empty:

I’ve also reselected both target and anchor many times.


Make sure you have to use CV activities inside CV Screen scope activity.

Hi there,

Of course I have everything set up in the CV Screen Scope! :smiley:

(The other Get CV Text activities are below that.)

HI guys I’m also encountering same error. please help to solve this
@BintaS any idea. did you find what the error is?

1 Like

Hey there, sorry but I didn’t get any other replies and couldn’t find the reason for the error so I just took out the CV activities. My guess is that they’re just too “new” and cause some bugs when used with other activities.


try using tesseract OCR instead of Microsoft OCR(default).
It will work.

1 Like

Hey, thanks - I had tried that as well, without any changes. But this is also quite old and I stopped working on this project because it didn’t yield any good results, so :sweat_smile:

I think tesseract OCR works better. Any reason why ?