Object reference not set to an instance of an object in Advance Assignment 1

Hi Team,

I am trying to resolve the Advance Training Assesment-1 when am trying to Extract the Datatable in https://www.acme-test.com/work-items am facing error “Object reference not set to an instance of an object”

Could someone please help me up in resolving the issue.
{{
“message”: “ExtractDataTable : Object reference not set to an instance of an object.”,
“level”: “Error”,
“logType”: “Default”,
“timeStamp”: “11:00:46”,
“processVersion”: “1.0.6706.35891”,
“fileName”: “ExtractDataTable”,
“jobId”: “00bf87e5-7b68-437b-889d-1f4d1b1e0173”,
“robotName”: “PRASA”
}}

Regards,
Prasanth

1 Like

@Prasanth_kolla Give default value to ExtractDataTable in variable section. I think it will solve your problem.

The DataScrapping did not work accurately at that time see that data is getting scrapped properly. This error means that table has not been initialized before you started using that in some statements or the table is empty and you have used it

can you please help me what can i provide in the default value ? am not sure of the Default value for the Datatable

@Prasanth_kolla “New System.Data.DataTable” give this value to default value in variable declaration. IT may solve your problem.

{
“message”: “Object reference not set to an instance of an object.”,
“level”: “Information”,
“logType”: “User”,
“timeStamp”: “11:59:00”,
“processVersion”: “1.0.0”,
“jobId”: “601c6c69-a9aa-424c-9571-ead4d9f305c3”,
“robotName”: “DMIKKILINENI”,
“machineId”: 0,
“fileName”: “AutoEmail”
}

i got this error can someone assist me

@deepak_mikkilineni youmight have Missed variable assignment in some activity, you might be doing some operations on variable which is null because of previous steps.

I am also having the same error while assingning the filtered dataitems to WIList

Iam also having the same prob while assigning filtered data items to WIList. It says object reference not set to an instance of an object.

Hi @Keerthana_Jegannatha can you take a screen shoot in debug mode ?

Hi thanks for the reply. I fixed it somehow.

Hi ,
I am getting the same error but in different kind of activity. Its an email automation process where in switch case while reading the subject of few emails i am getting this error. Can you help me?

@Sakshi_Gupta You might be getting that error because of variable doesn’t contain value in that activity. Please check the variable from where you get the data.

But if i am reading 50 emails then it is giving output for some emails and after that throwing an error.

@Sakshi_Gupta If possible can you upload the xaml file?

Main.xaml (12.3 KB)

Here please find the file attached.

Hello Keerthana!
How are you? I am facing same issue. Please advise how you resolved it? Would appreciate it, thanks!

i gave “New System.Data.DataTable” to default value in datatable variable declaration. And it worked for me.

1 Like

Hi Manjut, it worked for me. Thanks!

1 Like

@Keerthana_Jegannatha! Thank you for responding. Yes, it worked too.