NullReferenceException Error


#1

Hi,

As per screenshot below, how to resolved this issue?
The excel file was created how ever no data even though the source have data.
image
For reference I have created simliar sequence to the original file due to PnC .attach the xaml file as well (pls ignore the variable here, because there have no issue for original file)Today.xaml (3.0 KB)

Please help.

Thanks


#2

Unfortunately, I don’t see anything within the workflow. Its just blank for me.

Can you explain for which activity do you see this error? Is it happening when you are reading the row value from the DataTable?

Thanks,
Rammohan B.


#3

Hi @Rammohan91

Thanks for your response.
Sorry for the mistake.
Reattached the xaml file.Today.xaml (10.5 KB).
The error prompted at ReadExel in RowCount activity.The File exist.xlsx created by WriteCell activity but no data has been extracted to excel.
The same activities have been used in another sequence but its work fine.
I dunno why got error for this sequence.


#4

It means that your datatable is empty or nothing. Please make sure that you are assigning data table via import arguments or not


#5

Hi @ravisangam

Ye i know the data is empty but why for other sequence which i have use the same sequence has no issue.
Exactly the same sequence and activities but this one got an error…other no error.Why the data is empty for this one although the same variables/properties setting same with other sequence.


#6

is that data table is common variable to both the sequences? or different? if different check whether you are creating datatable variable with value as "new Datatable " or not


#7

Hi @ravisangam

Datatable is common variable for both sequences.


#8

Hey @azmee_zainol,

I made it working, please check the attached xaml.
Today (1).xaml (11.4 KB)

The only change that i made to your workflow is to remove the ‘For Each’ loop and add a new one with the same sequences.

As much as i remember, Initially there were 2 for each activity for UiPath studio, one of which has been deprecated.

Let me know if it still doesn’t work for you.

Thanks,
Rammohan B.


#9

Hi @Rammohan91

Thanks for your effort.How ever i cant open your xaml file.
Prompted this error message

Could not find member ‘CurrentIndex’ in type ‘http://schemas.uipath.com/workflow/activities:ForEach(String)’. Row: 68, Column: 46

However i managed to solved the issue by deleting and creating again the same sequence as before and tried relaunched and no issue persist.

Thanks for yr time n effort.


#10

Great. :slight_smile:

Just curious, whats the namespace of the ForEach activity that you have? Is it the same as below?

image

Thanks,
Rammohan B.


#11

Hi @Rammohan91

Yes, exactly same with yours.