Nuget Package not seen in "Manage Packages"


#1

Hi
I have created a Nuget package from a custom dll. I am using UiPath Community Edition. Hence I put nugget package in below folder shown in screenshot
Nuget

But when I opened UiPath and open “Manage Packages” menu, it doesn’t appear there. Please refer full screen shot below


Levenshtein distance
#2

Just to add more info, I have referred below link to create nugget package


#3

Hi,
Please follow up this.

  • In the Manage Packages window, in the left panel, right-click any category.
  • Select Configure Sources from the context menu. The Package Source Settings window is displayed.
  • Click the Add
  • In the Name field, type the name of the package.
  • In the Source field, type the local drive folder pathway, the shared network folder pathway or the NuGet feed URL of the package.

Refer


How to convert PDF to BLOB datatype
#4

Copy the Nuget Package File to C:\Program Files\UiPath Studio\Packages folder and check once again.


How do I execute a package created with UiPath Community Edition?
#5

Hi. Did you find solution for this?


#6

Hi,

There is Local sources, right click and configure your local path to the package and you should be able to see them then.


#7

I’m having the same difficulty, attempting to use Community Edition (not installed in the Program Files directory, but Users\AppData location). I’ve added a local source to where my package resides. The new local source displays in the Manage Packages form, but my NuGet package doesn’t display as an option.


#8

All right, i was able to self medicate on this one, figured it out, for anyone else who may struggle to get this to happen, see below for several of my own missteps. Note that i was only looking to build out a class library to pass as arguments between Activities, it didn’t do anything else other than to provide a structured data type.

First, reference the link below (i know it may appear above this post somewhere, but just reposting it so it’s all in one spot):

Some lessons learned:

Creating the class library correctly:

  • You must add System.Activities and (optional) System.ComponentModel.Composition libraries into your visual studio project. I thought those references were only necessary to create visual components, not an abstract class library. Bad assumption on my part.
  • When creating a public class, it has to be of type :CodeActivity
    - eg. public class AutomationRecord:CodeActivity
  • You will get an error message in Visual Studio, you can apply the fix based on Visual Studio’s suggested solution, or you can write the following method within your class object:
    So, all in all, your class should look like this (note this is in c#):

class AutomationRecord:CodeActivity{
public string MyCustomProperty1 {get; set;}
public string MyCustomProperty2 {get; set;}

    protected override void Execute(CodeActivityContext context)
         {
             throw new NotImplementedException();
         }

}

When creating the nuget package:

  • You don’t have to, but in that link, there is a nuget package manager that i was only able to successfully install through the github reference, because i’m working on Windows 7. Initially I attempted to build the nuget package through other mechanisms in visual studio, which could work, but the package manager made it much clearer what i had to do and where.

  • Ensure you add the word ‘Activities’ in the nuget package ID field (they call it out in the link)

That was it, hope this helps anyone who has reached this section of the thread in troubleshooting!