Nuget Package is not shown in Activities Tab

studio
package
custom_activities

#1

Hello All,
I’ve Created a class library in Microsoft VS2015 after building the solution I create the Nuget package with the help of its .dll file.but after installing this file in UiPath I didn’t see the package in Activities Tab. I also restart the UiPath thrice. please help


Execute C# code in UIpath
Execute C# code in UIpath
#2

WHere you have placed your package?


#3

I’ve placed the package in “Uipath Studio/Packages” folder


#4

Hi,
Copy the Nuget Package File to C:\Program Files\UiPath Studio\Packages folder and check once again.


#5

Hello @ddpadil sir,
I have done this 4-5 times but it didn’t work.


#6

No need to place even at packages folder

image
In order to deploy custom activities click on Manage Packages > In package manager > Right click > Configure sources

You can add

  • a shared network folder
  • a nuget feed URL
  • a local directory or system where your nugat package is.

after configure source you will be able to see your source

image


#7

Okay @aksh1yadav I’ll try this also. and let you inform


#8

@aksh1yadav Sir I’ve Tried this method also. Same issue Occur.
I create a new Nuget package file and install it in Uipath with your described procedure but Same problem occur i didn’t see it in My Activities Tab.


#9

I dont know something is wrong at your end. will you show me the screenshot ? or your package as well upload. it is simple. where you are showing and how you are configuring your source? and after configuring where you are searching it?


#10

Did you check this.


#11

@ddpadil Sir, I’ve Checked this and also change the build options to both x64 and x86 but it didn’t work


#12

Do you have activities in that package? IRegisterMetadata implementation?


#13

@andrzej.kniola No Sir. I’m Using “CodeActivity” in Package instead of IRegisterMetadata


#14

I’m Sharing Some ScreenShots Which shows the configuration of source and where I’m searching the Package file(in Activities Tab).
A.)


then
B.)
C.) After Installing the package file.i search these packages in my Activities
3


#15

you have installed your package in UiPath and your activity is not visible is this your problem…??


#16

Yes ma’am. activity is not shown in Activities Tab


#17

Try adding a blank space between capitals (“My Package”) and search without numbers.
Alternatively clear the search and manually look through the list.


#18

Activity name will not be same as your package name
Activity Name is always the class name you created in code activity. please search for the key word same as your Class name which inherit the code Activity


#19

So now u are able to install it.

What is the namespace name in your class file? have you given any?and here what activity name you have given that you should search not a package name. @manish110


#20

yes I give class name as “multiply” and activity name is same as package name.but it didn’t work