UIPath can't see custom nuget package

I built a custom activity following this demo from UIPath: DEMO: Build custom activities in minutes with the UiPath Activity Creator - YouTube

I’m using Visual Studio 2019 targeting .NET 4.6.1 and Publishing creates a package like this: tci.uipath.pgp.Activities.0.1.0.nupkg. I can open the package with an editor and verify that it is valid.

When I copy the package into ‘C:\Program Files\UiPath\Studio\Packages’ and open UIPath, the package doesn’t show up and there are no errors. What do I need to do so UIPath can see it?

Thanks,
Matthew

Hi,

I think there are 2 possibilities for the cause.

  • Put nupkg at wrong place.
  • The package has some error for activity.

Which version/edition of Studio do you use?
We can check feed URLs where Studio searches in Settings-ManageSources as the following.

Or can you share your nupkg as a file, if possible?

Regards,

Yoichi,

Thanks for the reply. I’m using Community 2021.10.4 and placing packages in the default local folder:

I’d be happy to share the nuget package. The forum won’t let me attach files for some reason, I uploaded it to a file sharing site: https://spaces.hightail.com/receive/KUtV11VRW2

Any ideas you could provide would be greatly appreciated!

Thanks,
Matthew

Yoichi,

Thanks for your reply. I’m using Community 2021.10.4 and using the default local folder for packages:

I’d be happy to share my nuget package. The forum won’t allow me to upload files or post a link to dropbox, etc. How can I share it with you?

Is there a way to make UIPath log results of scanning package folders? At this point I’m stabbing in the dark.

Thanks,
Matthew

Is the package marked as a prerelease version? If so, in the Manage Packages window you have to click the filter and select “show prerelease.”

Good thought. I checked and the package is not prerelease. I also tried all the package filters in UIPath with no luck.

If I create a new project in VS 2019 I can add my nuget package with through the manager:

So VS recognizes my package but UIPath does not.

Hi,

In my environment, your package seems no problem as the following.

So can you try to put it at some local folder (such as c:\temp), then set the path as feed at Settings in PackageManager?

In addition, can you check if your project of UiPath is Windows Legacy compatibility? (It doesn’t work in Windows (net5) compatibility)

Regards,

Yoichi,

Compatibility was it, working now. I spent the morning figuring out how to rebuild my activity using these instructions: Migrating Activities to .NET 5

If anyone else tries this, activities built using the UIPath VS Template for 4.6.1 can’t be retargeted; I kept running into reference errors in the build and eventually had to gut it.

Thanks!
Matthew

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.