NuGet Package Dependency Version Conflicts

I’m using Studio 2018.4.4 and have a project with a dependency on UiPath.UIAutomation.Activities 19.5.0. I want to include a reference to the latest Json Net package (12.0.2 currently) but it’s causing issues due to version conflicts.

Trying to utilize it to configure some things produces an error:


error BC30560: ‘JObject’ is ambiguous in the namespace ‘Newtonsoft.Json.Linq’. At line 1

And the line of code:

Dim config As JObject = JObject.Parse(File.ReadAllText(configPath))

The activities lib depends on v11.0.2 so it appears it’s not using my v12.0.2. This should work, but it looks like Studio is including all versions of all dependencies on execution. If I downgrade my Json Net version to 11.0.2, it will then work, but I don’t want to have to do that.

What are my options here?

Hi @jmercado

Welcome to the UiPath Forum! :slight_smile:

I believe downgrading is the workaround here. I also think this issue was fixed in the later versions of Studio (2019.X), so upgrading to the next Enterprise Edition 2019.4 might be the way here.

Otherwise, I would suggest you to contact our technical support for further assistance. I am not sure, but maybe the issue was also fixed in the 2018.4.5 patch.

Thanks. I’ll check with tech support.

I thought studio would auto update itself so I thought I was on the latest since it wasn’t going any further. I’ll just need to figure out what the process is for updating or otherwise changing versions. It doesn’t seem like studio has a way to initiate an update.

Edit: I just redownloaded the platform installer from the link provided in my email and it looks like it’s on an updated version. I presume this is how we need to perform updates.

Updating to 2019.4.3 Enterprise didn’t fix it, same error. I’ll see what Tech Support has to say about this.

In the mean time, I’ll just keep it at the older Json Net version so it doesn’t hinder development.

Thanks for updates. I hope support will be able to assist here.

As to the download links and how to update - the Community Edition .exe installer is the one that allows you (or restricts you!) to auto-update.
The Enterprise .MSI installer is purposefully stuck at the specific version of that installer file, just so you can decide when to update.

Also, with our new UiPath Cloud Platform - Public Preview, you can download both installers directly from the Resources tab :slight_smile:

So this appears to still be an issue and would have to be worked around if I really wanted to use the different versions. But it’s not critical for me to use the latest of this lib so I’m ok with sticking to the older version.