Not possible to push code from Studio to GitHub

Hey Guys,

I already created a repository on GitHub but I’m not able to push the code directly from Studio to the referred repository…the only way possible is uploading the code directly on Git.

Notice that I’m trying to upload related to Test Cases (Testing module)…any idea?



Hi @jose.penetra
Welcome back to UiPath forums!

Please read these docs for more help on this topic:

According to the docs:

The above may not be relevant, however just to add to this, if your organisation/github org has two-factor authentication enabled, it’s worthwhile to create a personal access token which authorizes git commits and makes life easier!

Good luck with the integration and please share how it went.


I’m using the free version of GitHub…is this a problem?


The problem is solved, by generation a token everything is working fine.

1 Like

Hey @jose.penetra
I am glad it worked for you!!
Please consider marking my answer as Solution so the topic will close automatically and may help someone else in the future.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.