Not ble to connect Robot with Orchestrator

Hi Team,
I am trying to connect UIPath Robot with orchestrator. As part of Orchestrator training , First we Provision Machine and then robot. After that we use UI Path Robot to do orchestrator configuration. In the Orchestrator setting the [Connect] button is coming as disabled for me.
Please help. I am also attaching screenshot here.
I am using UI Path Community Version 2019.10.4

You should check if the Uipath Robot’s service’s running normally on your machine

Thanks for reply @Doanh ,but i am new to UI Path.If you can suggest where to look and if not running ,how can i start the robot service.

You can access Control Panel > Administration Tool > Services
In list of services, looking for Uipath Robot service. If its status is not Started, start it.

1 Like

Thanks for reply.
It wasnt showing UI Path robot services in list of services but was able to seem them in the Task manger
I kiiled the UIpath Robot services and restarted studio and robot and this time the connect button was enabled.

Thanks Again.

1 Like

There could be multiple reasons for this particular error.

  1. Have you provisioned a Robot in Robot section against the Machine that you have shown in the screenshot?
  2. Is your machine is a closed environment where you need to go through a proxy to connect to external network? Like Office machines does not allow to connect to open internet directly.
1 Like

Hi Sahil,

1.Yes i did Provisioned .
2. Yes i am using office machine but via home internet.May be proxy was causing issue.But as replied earlier once i killed the robot services from task manager and restarted it ,i was able to see enabled connect button.

Thanks for your reply.

The error message was “Error Connecting to Roboto Service” - so it’s related to UiRobot service in local machine