Not able to run UiPath robot in administrator mode

I am building a Uipath robot to automate some actions in Tableau. First, when I wanted to use an Attach Window activity I got the error message:

Cannot access target process! Elevated priviliges might be required. Try running UiPath as an administrator.

To solve this I tried to update the Compatibility settings as discussed else on this forum, only without success. Now, I am running the UiPath studio as administrator and this error message disappears and I can use Attach Window in Tableau. However, when I try to run the robot I get the error:

Access is denied. Unable to start execution.

Does anyone know how to solve this?

Are you using a standard user or a guest user account? pls check the current user account permissions.

@GBK Thanks for your reply! Do you know where I can find the current user account?

Navigate to Control Panel\User Accounts\User Accounts
Your account will display your account type…

Or
Open command prompt -
type - net user “user name” ( ex: net user “ccc1”)

1 Like

@GBK Thanks! I am just logged in as a standard user. So, strange that UiPath refuses to run. When I open a new UiPath window (not in admin mode) I can run the robot but I get again the Cannot access target process error

it could be a privilege related issue… as it is working fine when you run as administrator…
if its your personal machine - add your user to administrator groups and check… if noy maybe you can request your admin teams to add your user to the machine administrator groups for verification.

I am getting exactly the same issue. I’m new to UI Path but I’m a fairly tech savvy user. I’m trying to open an application from Studio and I get exactly the same error: “Cannot access target process! Elevated priviliges might be required. Try running UiPath as an administrator

If I run UI Path as administrator it allows me to select the window but then when trying to run the application (or even just notepad.exe) I get: Access is denied. Unable to start execution

This is my personal PC and I only have one user account (‘user’ which is administrator).

Very frustrating first experience just trying to open an application from Studio!

Anyone solved this one?

@mhaz I’m having the same problem, did you manage to solve it?

Check this post. It might help you with Tableau


Always make sure that the robot user/service is allowed to run the application.

Second: running UiPath as Administrator can give you other errors when using the debug function: Access denied_1