Cannot access target application. Elevated privileges might be required. Try running UiPath Studio as administrator


I am having some issues trying to interact with the Windows system tool to work with active directory called CCM.EXE. I am in a virtual client using an account with administrative rights over the machine and a part of the Active Directory where is going to be created the network users. But when I tried to “spy” any object in the app, the following message is displayed: “Cannot access target application. Elevated privileges might be required. Try running UiPath Studio as administrator” (important to highlight that my account has administrative right over the virtual machine)

Because the account that I am using is in the group of Administrators and has administrative rights, I tried to run UiPath Studio as administrator. In this case, UiPath Studio finally recognize every object of the app, but when I tried to debug or run the project, the following message is displayed:

“Access is denied”

voiding any intent to run the process. I checked the connection to the UiPath Robot Service and when you run as administrator, there is no connection of UiPath Studio with the Uipath Robot Service. Have anybody experienced something similar?. What kind of special rights must have my account to capture interactions with CCM.exe?. Or, what I have to do to run the process as Administrator and not receive the message of “Access denied”?. Thank you very much in advance.


Check below for your reference

Hope this may help you


Thank you for your help Srini84. I already try before what this document says. Running UiPath as Administrator and is able to capture everything inside CCM.exe without issues. But the problem is that when I run the project (or debug) UiPath trigger an exception telling “Access denied”. And when you check, there is no communication between UiPath Studio and the “UiPath RobotJS” window service when your run Studio as Administrator. I need to fix this issue in order to automatically run the process with this higher integrity level. Thank you very much for your comment anyway,

Hi ,

Were you able to resolve this issue? I am able to capture the element of the application by launching the Studio in administrator mode but while running the process getting an error: - " Access is denied" in debug\normal mode.

Kindly let me know if there is any solution to this issue.

Thanks in advance.


Hi @sun.tom78, any of the actions taken to try to resolve this issue didn’t work. I finally installed the UiPath.ActiveDirectoryDomainServices.Activities package as a workaround and from there I could make all the administrative tasks needed in my process for Active Directory objects