Not able to identify SAP Tables

Hello everyone, this is my first post here on this community.

First of all i would like to thank all the participating members for their input, keep it up!

I started creating automations with UiPath 2 months ago, and now my issue is with the SAP software, i am not able to identify the column headers, and the “row headers” on a table.

When i use the click activity, it is possible here :

But not here, when i want to click on the checbox corresponding to the item in question :

N.B : Scripting is enabled on both ends

Your help would be much appreciated people :wink:

Hi @Meloueh01

Is Enable SAP GUI Scripting extension been installed?

Ashwin S

Hello Ashwin,

I wasn’t aware there was an extension to install, but if this is what you are talking about, i have followed these steps :

If there is an extension to install, please post the link below.


Hi @Meloueh01

Go to start=>Tools=>Enable SAP GUI Scripting option will be there

Ashwin S

@Meloueh01 Can you tell me what you want to do, Like Are you Trying to Extract the Table From SAP or just trying to Click the Checkbox?

I have already done that buddy.

Hi @supermanPunch , thank your for replying.
I want to click the checkbox, so the project can be selected.

The issue is that i cannot find a real link between the checkbox and the item that goes with it.
In some cases there can be multiple checkboxes.

Hi @Meloueh01

Have you tried using check activity

Ashwin S

Yes i have, same issue :confused:

Once i cannot select the checkbox with the click activity, no other activity would work.

Hi @Meloueh01

have you tried by using send hot key as tab

Ashwin S

@Meloueh01 Can you try using Recorder and Check if you were able to Click the Checkbox?

The tab hot key is not taking me to the checkbox, but somewhere else.

It’s not working, same issue i’m facing with the click activity

Hi @Meloueh01

Check this

Ashwin S

@Meloueh01 The Click on a Checkbox should work if Scripting is Enabled on Both Server and Client Side though, Can you Show us the Selector After you try to click the Checkbox ?

Here is the selector, let me know what you see :

<wnd app='saplogon.exe' cls='SAP_FRONTEND_SESSION' title='Feuill de saisie des temps : vue de saisie' />
<sap id='usr/subCATS001:SAPLCATS:2100/tblSAPLCATSTC_CATSW' />

And the selector for the first item in row :

<wnd app='saplogon.exe' cls='SAP_FRONTEND_SESSION' title='Feuill de saisie des temps : vue de saisie' />
<sap id='usr/subCATS001:SAPLCATS:2100/tblSAPLCATSTC_CATSW' tableCol='0' tableRow='10' />

@AshwinS2 The link you posted allows you to get the value stored in the checkbox, which is not what i want, i want to click that checkbox and do further action.

@Meloueh01 Have yo used other Frameworks and Checked?

What do you mean by other frameworks?

I have worked in the past with the checkbox on a Word Document, and everything went smoothly on UiPath side.

@Meloueh01 In UiExplorer you can Find Ui Frameworks Options, Can you Look through that , and Check if you find a valid Selector

Same result buddy, i have tried the ‘Active Accessibility’ and ‘UI Automation’

The selector of the checkbox remains under the parent selector, and i can’t click on it.

hi @Meloueh01

A few asks:

  • Please give the transaction number, that I can reproduce it on my side
  • Which UiPath Studio version you are using?
  • Have you tried it with different SAP Theme? Blue Crystal?

Thanks, Lev

Hi @LevKushnir
Thank you for stepping in !

  • The transaction number is cat2
  • My UiPath version is the following : 2019.4.4
  • I have tried with the ‘SAP Signature Theme’ not the Blue Crystal

Should i try this theme?

Thank you again