No robot is show when i create a job in orchestrator

Dear Community!

I’m facing an issue trying to do Lesson Orchestrator 2018.3 - Practice 3 in which i have to create a job in Orchestrator. When i try to create it, i cannot find any robot.

Robot is correctly defined in its environment and in orchestrator

I specified domain and username, copy/pasted from command ‘whoami’ in cmd.

License: Community Edition
Version: Studio 2019.10.4
Package: OrchestratorHelloWorld
Environment: EntornoCasero
Robot: CaseroS1 (Studio Type), Status: Available, connected and licensed.
image

If i create de Job using “Allocate dynamically” option, it never executes, remains in a “Pending” status.

That process can be executed normally from desktop robot.

I don’t know what i’m doing wrong, or if just can’t do it with Community Edition License.

My Windows username has a white space (thanks, Microsoft accounts). Could be that whitespace’s fault?

After some test and troubleshooting, i realized than ‘Studio’ Type robot can not run processes from orchestrator any more and now i must use an ‘unattended’ robot.

I create it now, and it can be selectable from “create job”, but after that, job still has a “pending” status and it doesn’t execute.

I tried to restart application, delete environment, robot, and even complete Service, but Job doesn’t execute properly.

I changed my Windows username to Alberto_VR as welll (https://stackoverflow.com/questions/35175814/windows-10-username-with-whitespace-and-path)

What am i missing?

2 Likes

This is how i have setup my CE setup

1 VM with studio installed and connected as type: Studio
1 VM with only the robot installed and connected as type: Unattended

I develop on the studio, publish my packages to Orchestrator. I test FROM studio on studio, but not from orchestrator > studio. That is where the robots are for.

It is making things a lot easier when you are testing/learning.

The workaround would be what you also did:
Orchestrator: Change the robot type to Unattended. Change the setting for your robot: (Login to console: Yes)
Studio: disconnect the robot and reconnect it. Sometimes wait a couple of minutes to let things sync.
Orchestrator: refresh orchestrator and you should be able to start a job. Keep your studio machine logged in.

If your job is not starting, check the robot logs if you something there.
C:\Users\Alberto_VR\AppData\Local\UiPath\Logs

Can you show what your job is doing?

2 Likes

@Albertovr Most Probably because your Robot is of the Type Studio, change it to Unattended and Check.

1 Like

Thank you both for your reply!

As you said, visibility problem was solved just changing robot type to "unattended’, but it still don’t execute the jobs.

Of course, i disconnect/reconnect robots, and create new jobs (and killed old ones).

Job is so simple, just a Message Box

@Albertovr I actually Tried it in mine, It worked smoothly :sweat_smile:, Can you tell me if you have faced any error?

Nop, I tried again, but it’s still pending.

@Albertovr Have you provided your full username while Creating the Robot with the Domain Name?

Yes, copypasted from command ‘whoami’ typed in cmd

Job is still pending, but i click on detalis, and this window is shown.

image

I have only two robots, one Studio type in other environment, and this unattended in EntornoCasero environment.

And 'CaseroU1 is, apparently, still icensed, available and connected.
image

Solution to unlicensed/licensed robot:
Going to user -> check “unattended” robots, disable one (system creates two unattended robots due some bug), then, take your robot, change type from ‘unattended’ to ‘attended’ and change it again to ‘unattended’.

Now your jobs will be running again.

Solution found here -> Robot Licensing Failed. There are no available licenses on the server. (#1914)

2 Likes

Good to see you found the solution. Thx for pointing to the solution which can be very helpful to others.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.