No open windows found "program".exe. PLease check if application is running


I am having trouble running this file I have this intermitent error usually I do a reboot and it work but this time I can’t seem to get over that error. When I go into UI explorer and check with HIghlight it finds the window I am looking for but when I run it sends this error below.

I tried removing/adding the ctrlname and/or title but it still can’t find it.

Any body have ideas to help me?
Source: Attach Window ‘ShellForm Managemen’
Message: No open windows found for ‘managementfinance.exe’. Please check if the application is running.
Exception Type: UiPath.Core.SelectorNotFoundException

RemoteException wrapping UiPath.Core.SelectorNotFoundException: No open windows found for ‘managementfinance.exe’. Please check if the application is running.
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.Core.Activities.ObsoleteAsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Hello @GRH1405
Can you please share the selector used in the Attach window activity?
Also as you mentioned earlier it was working and now it is not working. Any recent updates of label changes happened?


Hello @Rahul_Unnikrishnan,

here is the selector


I have not made any changes since the last time it ran properly


This seems to be valid. But can you select that window again to get the latest selector for the attch window activity.

Also update all yhr uipath packages to the latest stable version.


Any update in the Web portal @GRH1405



I have update all packages to latest version and have reindicated the window on the selector, it still comeback with the same error.



I am not sure where to find this info but my target desktop application was not update.


Have you considered running a quick check if the process is running?

You can use the Get Processes Activity to get a Dictionary of type Process to have all the processes running.

See attached an xaml with a check if your process exists. It returns a boolean for argument ProcessExists.
It is set up as a Library so you can Publish it within a project library and use it in your flows. (note that the default value is GoogleUpdate. Replace with your process name and leave it blank if you’re turning it into a Library item.)

Secondly, I would log into the unattended computer with the robot account and run your process from Assistant to see the behavior as it happens. It really sounds like the program is not launched.

ProcessExists.xaml (8.8 KB)

can you please run it in debug mode, step into method, and share the error here?
Also, enable highlight element.