No labels when trying to use Find Element in PDFs [Solved]

I’m am following the course “Level 1 - Foundation Training”. I’m at Lesson 10 - Practice 1.

When I try to do as told in the exercise:
Attach to the PDF Reader window using an Attach Window activity.
“Drag an Anchor Base container inside the Do block:”

  • “on the left side, we’ll drag a Find Element activity to select our anchor.”
  • “we click Indicate on screen.”
  • “we click the DATE label next to the actual date we are trying to get.”

I am expected to get the following result:
(New users can only post one picture, there should have been a picture here indicating the DATA label with a red square)

However when I try to select the label, it acts as if the PDF is an image format, and not a text format.
The PDF is downloaded from the course as I have a picture here showing, that I am able to select and copy text from the PDF:
(still only allowed to post one picture, should have showed that I can select DATE in the PDF with my cursor in the PDF, which is only possible if it’s a text format and not an image)

What happens when I try to select the label with Find Element → Indicate on screen is the following:

I have tried to indicate the location of DATE anyway and the picture here shows the selectors chosen from it:
(still only one picture, here I would have shown that the selectors are insufficient, since it cannot find a label indicating DATE)

I have tried with Adope Reader as seen in the pictures.
I’ve tried it by opening the PDF via the browser.
I’ve tried opening the PDF in SumatraPDF.

I’ve also tried with and without Attach Window with no effect either.
I know that the problem is solvable with OCR, but that’s not what the task is about, and since the PDF is in text, I should have to use OCR since it’s less accurate and not as efficient.


Here is what I’m expected to get when I use Get Element and Find Text:

Here is the picture indicating that the PDF is in fact in text format:

And lastly showing my selectors after trying to use Find Element:

I think its Adoobe Reader XI vs Adobe Acrobat Reader DC.

Selectors works fine in Adoobe Reader XI

Where as in Adobe Acrobat Reader DC, if you disable “Enable Assistive technology support” it works.

Edit > Preferences > Accessibility



Thank you!

I didn’t work when I tried to download Adobe Reader XI, but going to Edit > Preferences > Accessibility and turning off Enable assistive technology support worked!


I disabled the Enable Assistive technology support" option in Adobe Reader DC, and re did the find element & get text pieces, but when I run it, I get an activity timeout error on the first GetText

Which error are you getting?

Maybe you could attach a picture of your activity as well.

fyi - I downloaded the Lesson 10 Practice 1 answers and tried to run that automation and I got the same error, so… not sure what’s wrong

It does seem weird. However it is not really related to the problem I had. So people who might know how to fix your problem, might not come here to answer it.

I would suggest looking through the forum for an answer. If you are unsuccessful, create your own post. People usually respond pretty quickly.

Best of luck to you.