No endpoint listening at net.pipe

It seems like quite a few people have had this error, I’m trying to execute a process called TestProcess remotely via PowerShell.

If I run

.\UiRobot.exe -file "C:\Users\xxx\Documents\UiPath\TestProcess\Main.xaml"

locally then it works fine, my process runs. Now I try working on another machine and attempt to invoke this command on the original machine, using the following:

Invoke-Command -Credential $mycreds -ComputerName $originalMachine -ScriptBlock {
.\UiRobot.exe -file "C:\Users\xxx\Documents\UiPath\TestProcess\Main.xaml"

This gives me the error

There was no endpoint listening at net.pipe://localhost/UiPath/service/duplex/agent/xxx that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.
    + CategoryInfo          : NotSpecified: (There was no en...r more details.:String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError

Some more points:

  • I’m using the community edition installed with the .exe installer v19.5.0.
  • Remotely running other PowerShell commands works fine between the two machines.
  • I’ve tried reinstalling and adding the .Net features suggested as here.
  • I’ve tried running under various different users with various access levels.
  • I’ve tried putting the command I want to run inside a .bat file then trying to execute that remotely.
  • Interestingly, trying to use Invoke-Command to run the process in the exact same way on localhost (as opposed to the earlier remote method) doesn’t work, I get the net.pipe error again.
  • I don’t see any UiRobot Windows service, but I gather that is because I am using the community edition.

Any help would be much appreciated, I’ve spent all day trying to solve this

Are you running Script in Administrator Mode? Check if UiPath was installed over same user you are using to run…

Hi, yes I’m running it using my credentials (myUser\myPassword) and it’s installed in C:\Users\myUser\AppData\Local\UiPath.

I’ve checked to see if myUser has elevated privileges by invoking whoami /priv on the remote machine rather than trying to execute the process, I get 24 privileges which seems to mean it’ll be running in admin mode after a bit of googling.