No endpoint listening at net.pipe://localhost/UiPath/service/duplex/agent/<USER> that could accept the message

Hello All,
I installed UiPath Community 19.7.0 free addition, but I am getting this no endpoint error for a whole day.

I’ve gone through all the questions related to this error and tried almost all solutions that are suggested. Here are the few things I tried:

  1. I’ve made sure Net.Pipe Listener Adapter is running
  2. Turned on all features under .Net Framework from Turn windows features on/off .
  3. My user account(which is not default administrator account) has administrator privileges. Also I have full control over C:\Program Files\WindowsApps
  4. I’ve reinstalled several times after clearing from Roaming & Local folder.

Weirdly, I didn’t face any problem in another machine where the account is default administrator account. A note: It ran there without any Ui Robot process.

Here is the detailed error log if any one wants to see:

15:44:10.5562 => [ERROR] [UiPath.Studio.exe] [1] System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at net.pipe://localhost/UiPath/service/duplex/agent/suddin that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.

Server stack trace:
at System.ServiceModel.Channels.ConnectionUpgradeHelper.DecodeFramingFault(ClientFramingDecoder decoder, IConnection connection, Uri via, String contentType, TimeoutHelper& timeoutHelper)
at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.SendPreamble(IConnection connection, ArraySegment`1 preamble, TimeoutHelper& timeoutHelper)
at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.DuplexConnectionPoolHelper.AcceptPooledConnection(IConnection connection, TimeoutHelper& timeoutHelper)
at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)
at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.CallOpenOnce.System.ServiceModel.Channels.ServiceChannel.ICallOnce.Call(ServiceChannel channel, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.CallOnceManager.CallOnce(TimeSpan timeout, CallOnceManager cascade)
at System.ServiceModel.Channels.ServiceChannel.EnsureOpened(TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object ins, Object outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at UiPath.Models.IUiPathRemoteDuplexContract.GetRobotConnectionStatus()
at UiPath.Models.UiPathDuplexProxy.GetRobotConnectionStatus()
at UiPath.Studio.Plugin.Workflow.Services.RobotStudioBridge.d__24.MoveNext()

I often encountered this and restarting/rebooting the workstation fixed it.

@Emman_Pelayo Unfortunately, I’ve lost count how many times I’ve done that. Still no luck :frowning_face:

That’s sad. Have you tried installing lower version of community studio?

@Emman_Pelayo No, I can’t find any lower version from resource center inside my account page. There is only one community version 19.7.0

Hi @Md_Suja_Uddin

Could you give these topics a read?
https://forum.uipath.com/search?q=net.pipe%20status%3Asolved

Each will contain a post with a (possible) solution to your issue :slight_smile:

Hi @loginerror , I’ve tried almost every solutions . None of them worked :sleepy:

UPDATE
However I’ve managed to finally work around the issue. I had to either Uninstall the IIS or Turn it off from Turn Windows features on/off section. I am guessing IIS is blocking some port that UiPath needs to use. Stopping IIS from IIS manager doesn’t help :frowning:

But this will be huge troublesome for me as I need to work on another project which constantly require IIS. Can anyone tell me a simple workaround / fix based on the findings ? Thanks in advance

1 Like

I have found some mentions that this should fix the issue:

  • enabling all .net features in windows features
  • clean installation of Studio (see the guide below)

Could you confirm that it did not resolve the issue?