No connection could be made because target machine actively refuse it

Hi there,

Send SMTP activity returns the error as mentioned in the title. Please find the information and disclaimer below:


  1. Package dependency: UiPath.Mail.Activities
  2. Version: 1.9.6


  1. Able to send out one-time, failed subsequently. (Subsequent run fails)
  2. Telnet open, firewall not blocking. (Tested using elevated command prompt)
  3. Used PowerShell command to test smtp, able to send out (From same machine)
  4. Used PowerShell command to test send email WITH attachment, able to send out (From same machine)
  5. SMTP server does not require authentication

Help needed. Thank you.


Can you share the properties of Send SMTP Activity

If you are using Variables, can you hardcode the values and try again

Also, try with updating / degrading the mail packages

Hope this may help you



I can’t share the properties as SMTP information/credentials are confidential.

Values are being parsed as argument. Used hardcoded value, still the same issue.

Used same package but different SMTP server, worked like a charm, so I don’t think is the package issue.

I just want to know why powershell works, but this activity does not. Executes both test from the same machine.

Thanks for your suggestion.