My process keeps reverting back to old UiPath Activity versions (Possible Failure Point at Alteryx Packages?)

Hello All,

I’ve been struggling these last two weeks in seeing what the issue was. I’m seeing activity errors in my queue item activities (referencing the old Enterprise Queue Item and not the Core Queue Item type) even after uninstalling 20.4.1 Studio/Robot with 20.10.2 Studio/Robot. I even re-created my process from scratch, taking the 20.10.2 REFramework Template.

Once I recreated the process, making sure the Queue Items being used are referencing the Core.QueueItems type, I’m able to successfully publish my package to the Orchestrator (20.10). However after saving and closing the process in Studio. When I try re-opening, all my activities that reference the Queue Item type become invalid, and even my arguments for the Queue Items reference the old Enterprise type, not the Core type.

Error Messages:


My temporary solution was to delete the project.json and reopen the Main.XAML file. Interestingly enough, all the queue item types went back to the right updated type from the UiPath Core Activities. HOWEVER I noticed that my Alteryx Activities package was no longer present. (1.0.3)

When I tried to reinstall the Alteryx package, my missing activities related to Alteryx became valid and visible again and I was able to publish the whole project to Orchestrator. But then after reinstalling Alteryx packages, and closing the whole studio. I tried to open the Main.xaml file again. That time I got the missing errors again attributed to the old Queue Item types.

@Shawn_Ngoh I can’t reproduce this behavior, maybe there’s something I’m not doing or something missing from your bug description. Can you please attach a sample project here? If privacy is an issue, feel free to send me a private message with it. The Studio log would also be helpful, also via private message.

OK, so based on a sample project from @Shawn_Ngoh, we’ve managed to track the problem down to a very old dependency of the Alteryx activities package that needs to be removed.

The fix implies an update to the Alteryx activities package and there is no workaround as of now. I will come back with a reply once the update is available.


Hello Tudor,

Any update on the status of fixing the Alteryx Activities?

It’s in progress. I can’t tell you exactly how long it will be until the release just yet, but current estimations target the end of this month.

1 Like

Hey @Shawn_Ngoh! The Alteryx activities package v1.0.4 is out now and it contains a fix for the issue you’ve mentioned. Can you please test it and let me know if all is well now?


yes this part is working now. Thanks!