MicroStrategy - Click on 3 Dot Visualisation Menu on Grid

Hi, I’m trying to Click on a very small image that is present on the top right-hand corner of a Grid Visualisation. It’s so small on the display, the Click selector doesn’t isolate it for clicking.
See small square with 3 vertically aligned dots in the attached image.ThreeDot Grid Visualisation Menu

I’ve tried using Click Image with “Grab from Screen” and it works on occasion but not reliable. I sometimes manage to get it working again. But next day is a fail. Is there a better, sure-fire way of being able to click on that small image?


I don’t mean to revisit something could not work potentially, but can you supply a screenshot the web selector for it while it is reporting successfully located?

I tried fixing a bit further by using Find Image with Output→FoundElement to a Variable “ThreeDot” (UiElement variable type), then passing that variable to Click Image.
I’ve got it working now. See the screen-cap.

It seems to work. But if I run my sequence where my screen is slightly different (ex.: work on my laptop only vs use extended screens), then we’re back to a fail. The difficulty is, the square with the three dots is not technically part of the grid. It’s a selectable object that “hovers above” the presented grid. Right now, when looking at Selector, it seems to find the position in relevance to the 15th column of the grid. If my display is slighly different, then that icon (ThreeDot) may wind up hovering above the 11th column. So it’s not a very reliable way to get to that menu. Unfortunately, MicroStrategy don’t seem to have programmed a hotket to access the grid menu; that would have been a better alternative.

Any recommendations?

ThierryFindImage Selector cap

You should only use images if it is your last resort. They can become unstable at anytime where as a UiElement will continue to stay stable across any screen change or visual update a website may go through. Since you have found a stable selector try using this exact selector (Just copy and paste it rather then locating it again) in just a click activity and see what happens.

Is the website you’re working with a public site that we can examine the selector for ourselves? If not it’s okay.

There is some piece of code somewhere on their site that generates that three dots and is specific to that three dots. We can find it!

Hi Churchill. Sorry I was away for a few days over the Holidays.
Not sure if this is a public site. MicroStrategy is the BI system we use at work.
I tried to produce a simpler report to see if it might be easier to identify the HTML code that would identify the 3 dots. But I’ll admit I know nothing about HTML… I’m just trying to see what stands out.
Is there a way to look at a Web Page and look into the code behind it?

Yeah If the Built in Ui Explorer isn’t your speed then on any webpage you can use CTRL+SHIFT+C and it will bring the in browser element tool. Simply hover your mouse over the element on the page and it will highlight the code on the element tool. Let us know what you find!

Interesting!! Managed to select the button by Zooming in

And from the HTML panel, the following code was highlighted:

Tried pasting all of this into the Selector Editor but it doen’s seem to be finding the button

I got a step closer… I managed to find (I think) the right UiElement. Validation is green, it’s highlighting the right button - see screencapture attcchment. However, when I run the program, I keep getting “Cannot find UiElement”. Despite this, once the program is stopped, I re-open the Selector Editor and it’s still showing green validation. What Am I doing wrong?!? Can you help?

Hey are you by chance using a open browser or attach browser activity that contains these item? I assume you are but making sure. If you are I noticed your selector isn’t populating the first line (its grayed out) in your selector. This line is reserved for browser information when you select an element. A quick fix I do is re-select the element (it may take a couple trys) until you see that top line populate with your browser info.

I think I finally got it working. Always unsure about what are the right additional elements to consider to help make th selector solid… select class, parentid, parentclass, aria label…? From the training I’ve seen so far, it’s not very clear. If you have recommendations on this, please let me know. I guess we can consider this one solved! Thanks for helping out on this!

Can I see the actual on screen element as a normal user would see it? There might be something you can use as an anchor. Other wise if you are able to close the Ui Explorer, close the browser, and reopen it all and the selector holds you’ve found yourself a stable selector.

It’s stable now. Thanks for your help! Truly appreciated! :grin:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.